My Simucube 2 Pro doesn't turn on

Hi everyone, I need help please. I was quietly racing an iracing race, when suddenly my steering wheel started to spin abruptly on its own, to the point of disconnecting the usb cable from the wheel. I was quick and I released my hands quickly. Then I saw that it had turned off and there is no way to connect it. This happened while riding quietly, without any hit or anything like that.
I feel frustrated because it took me a month to finish mounting the update of some PC components, and when I finally have it this problem occurs to me. And to top it off, in 1 or 2 weeks I must have my new wheel from Pololo Instruments.
Has this happened to someone else or do you know what happened?
Thank you very much to all.

What have you tried to solve the problem?
Did you disconnect, then reconnect all cables to/from the SC2 and the 2 PSU’s?
Did you try different USB ports on your PC to connect your SC2 to?

Hello, I did the basics:

  • I disconnected all the cables and reconnected them (the power supplies turn on the light, so they carry electricity)
  • I connected on other usb ports.

The result was that everything remained the same. My Simucube does nothing to turn on.

I am delighted to receive your advice.
Thank you.

So when you flip the power switch, no beeps and no device detection in Windows either?

Is the E-stop pressed? Did you try to cycle that?

Can you try it on another power outlet, just to be sure that that isn’t causing it?

Windows does not detect any device. When I press the power button on the base it does not respond, neither sound nor led. They only turn on the lights on the power supplies.
I tried to do it with the E-stop pressed and without pressing and I get the same answer… nothing.

I’m out of idea’s then, sorry mate :frowning:

Hopefully someone from GD steps in soon to help you. Otherwise contact your seller, there’s a chance you need to send the base back.

Device will not turn on if it doesn’t detect USB. Can you switch out the USB cable with a new verified working cable?


Thanks Beano. It will be the next thing i will try. I hope that it was the solution. I am going to try it.

Cheers Mate, let us know - just throwing some ideas out there :slight_smile:

Hello friends, I have already found and solved the problem. Dumber than you could imagine. I had not seen that the wheel cable was broken.
It turns out that when I had the problem the steering wheel turned sharply and pinched the wheel wire a little. It was a clean cut, but it cut 1 internal cable and pinched the others without me noticing. And that made a short circuit that turned off everything connected by usb.
Solved with a small cut and 4 welding points.
I appreciate the interest and the help provided. As always, this is a great community that we learn from every day thanks to users like you.
Best regards,
Raul S.


Glad that you found and solved the problem! Happy racing :slight_smile: