Motor Faults: Overvoltage Power Stage Forced Off Fault Location ID: 0

Hi everyone,

I’ve had my SC2 for a few months now, and have enjoyed the experience very much. Recently in this past week, I have experienced the same error twice, both times it occurred right after powering on my SC2 Pro. Please see attachment. I rebooted the SC2 each time and it was OK after that. I purchased my unit in September, but only really started using it in October.

Overvoltage Power Stage Forced Off Fault Location ID: 0

Could this be some kind of power surge going on? I do have both powersupplies plugged into surge protectors. However, they are on two different outlets (two different circuits in my home, to spread out the power draw between all my devices). Is this a problem? Everything has been working fine for one month until this past week though. Any help you can provide is appreciated.

Simucube 2 firmware version: 1.0.26
True Drive Version: 1.0.26
Servo drive firmware version: 10821

Did you rotate the wheel before the system went to the Operational state?

Thank you for your reply, Mika.

Do you mean whether I moved the steering wheel in between the time I hit the power on toggle and before the software said “Operational”?

I don’t recall doing this, but if the wheel must be stationary during that time I will start looking out for this in the future and making sure I don’t touch the wheel immediately after pressing the power on toggle.

I have a second question: what is the recommendation with regards to the power state overnight? Should we turn off the wheelbase at the end of each day? I have been turning it off, but if I just left it on is that a problem? It does have a standby mode right?

Hello, I am having the same isue. Overvoltage message, a message abut with usb problem and one of time the wheel went totally to the right

has this happened during a driving session?

Thankfully I haven’t seen the problem since I originally posted, knock on wood.

I think the start up procedure might make a difference too. These days my SC2 Pro gets started before my Windows OS or TrueDrive software even boots up. Try starting the SC2 before starting your True Drive.

1 Like

Yes, And now it works les than one minute and it gets disconnected every time I try to play

I’ve recently experienced the same problem as OP. But I experienced it whilst standing in the pitlane, with the SC powered on for a while. I also used it to drive and it was fine. All of a sudden, I had this error and despite cycling the E-stop and the power button, it didn’t came back.

I was using 2020.4 at the time. I upgraded to 2021.12 after that because I thought that might’ve helped, but sadly it didn’t fix it completely.

I don’t have the error message anymore, but the engine makes a grinding noise when turning the wheel now.

You guys have any tips of stuff I can try out to get it working again?

Kind regards

We have seen your support ticket about this, and we are trying to figure out what it might be.