Motor faults: overvelocity

For efficient support requests, please consider using the template below. Fill-in the (blanks) and provide additional info when necessary. Thank you! Best regards, Granite Devices team.

I have a question regarding (simucube) regarding (overvelocity).

My hardware configuration:
-(ioni pro hc)
-(mige / 130ST-AM06025)
-(ioni 10707)
-(simucube firmware: 0.11.2)

Problems arise when:
I trying to set up a simucube from scratch. I clearly don’t have something right. I keep getting overvelocity fault after setup.
I also get an amperage fault when I try to run the “configure motor, encoder and center point” utility in simucube on hardware tab. I suspect this is due to improper wattage setting in granity. I just happened to notice this while looking at screen shots.

In the instances that I have gotten the overvelocity fault to go away the steering is extremely notchy.

I have attached following files:
Attached are pics of my simube settings and granity settings.

Any help would be greatly appreciated.

Note: you can tag the best answer as solution. This helps others to find the solution to the same question.

To handle over velocity:

You need to raise the value of FEV. I can’t remember the exact setting. I think it is around 20,000.
You want to end up around 8 rev/sec

I can’t help with the other things. I have never messed with that little motor

If the steering is notchy, put the AXI invert to different setting.

Also put over current tolerance to Maximum.

my suggestions , upgrade ioni firmware to the latest 1.7.16

you can put fev at the max setting allowed if you still have problems.

foc at max
fuv 30
mtc 1500

you don’t need mpp if you have the most common psu sdr

mmc at 6A is ok if you are testing , but it is way too low for this motor. 6A is the rated current in rms. But the values in granity are in peak of sine 1.414 times larger than rms. . I reckon you can safely push 18A to this unit . I would even dare to say 22A but i don’t have the time to do calculations.