Issues with Steam games


#1

Hi,

I have an issue that’s just started happening. Raceroom, wreckfest and Rf2 no longer work with simucube.

iRacing works fine and simucbe is detected no problem in DiView and windows controller.

I’m stumped, I’ve made no changes to the simucube since the November update.


#2

This is what’s happening in raceroom as well as no FFB, fast forward to 1.57

Rf2 and wreckfest can’t detect the simucube.


#3

Very interesting!

Does it also do the same, if the Simucube tool is closed?


#4

I never tried that. I’m doing the 24hr daytona at the moment so I can’t do much until tomorrow.


#5

Is it possible a windows update has caused this problem?


#6

I just tried again, but no luck.

I removed every possible usb device and hub, closed simcube software, no difference.

I going to try Richard burns rally as that’s the only car game I can think of that doesn’t use steam.


#7

I just tested RF2 and Wreckfest at home, with patches from last week for Windows 10, with Steam and the games with latest patches. Everything works.

I will now check if there are further patches since last week for Windows.


#8

There was a cumulative patch KB4483235
https://support.microsoft.com/en-us/help/4483235/december192018kb4483235osbuild17763195

It appears that it should only affect Internet Explorer.


#9

I’m not sure if I’m setting it up properly in Richard burns rally properly but it doesn’t seem to be detecting simucube as a wheel, it’s detecting it like a gamepad.

Same in Steam controllers it comes up as a gamepad


#10

OK, installed that patch to Windows 10, everything is still working.


#11

Are you using the Steam Big Picture mode? I’ve never used it, but tried just now. I have no idea what one is supposed to do with that in the controllers configuration; I though the whole point of that mode was to get easy access to games via gamepads etc, similar to a gaming console.


#12

I’ve tried big picture mode and normal mode. Everything is unticked.

I think windows is treating simucube like a gamepad and not like a ffb steering wheel. Does that make sense?

FFB is greyed out in RBR as well.


#13

Doesn’t really make sense to me on why that would happen; although Windows will show it as gamepad anyway as the default windows device driver / control panel applet does not know about steering wheels.


#14

One thing you could try, is to shut down simucube. Then go to Device manager in control panel. Choose View and “display hidden devices”. Then delete all hidden game controller devices you can find, and reboot.

After reboot, Windows will treat Simucube as a new device and should re-enumerate it.


#15

I tried this, made no difference. rF2 still doesn’t detect simucube.

I upgraded rf2 to 1.1112 and this comes with a profile for the simucube. But still won’t work as it doesn’t detect my simucube.

I’m at a loss, I don’t know what else to try.


#16

Mika, I found the problem. It was irFFB. :weary:

I’ve been in iRacing for the last few weeks only and forgot about irffb running in the background.

Thanks for your help.


#17

I spoke to soon, rF2 is still not working. “No connected controller detected”

But Raceroom is now fine.


#18

I found the problem with rf2 some how Steam input settings were changed to “Forced on” set to global and all good.