Issues with brand new simucube

Hi there

Finally got my simucube 2 pro in the post today. Unfortunatley having issues setting it up

I downloaded the latest ‘True Drive’ and once the firmware is updated this is all I have (hope the pic works)

Reset center keeps flashing between 0.00 and ???.??
State is stuck on waiting and E-Stop says pressed, even when its not and even when disconnected.

another pic for reference



Does the estop button seem to be working mechanically? Press and it will latch down, twist and it pops back up?

Estop needs to be connected to the wheel base.

guys i am also experiencing this problem, as soon as i switch on the base windows recognises it, but then it is not detected, i have tried pressing and deactivating e-stop to no avail. help!
last update TRUE DRIVE 2024.5+ RECOSTR. FILTER V2

the LED changes from green to steady blue.

same situation as moggy
I downgraded fimwire to version 2024.5 to no avail. :smiling_face_with_tear: :smiling_face_with_tear:

Does your e-stop button status track correctly?

correctly, one moment post video

mika started working again!!! i switched off the power supply completely for a minute and restarted the pc. It worked!!! i am HAPPY :+1: :star_struck: :star_struck: :star_struck: :star_struck: :star_struck: :star_struck:

I did a test playing 5 min. restarted the pc and now it’s not going again. :thinking: :exploding_head:

I’ll update you on my situation. Yesterday I ran some more tests. Let me start by saying that every time I turn off the PC or don’t play the base, I turn it off using the rear button. Whenever I need it I turn on the base and it was detected by the True Drive. Now, if I try to turn on the base from the back button, Windows recognizes the device while the True Dive does not detect the base. To make everything work again I have to unplug the two power supplies from the power strip for about a minute and reconnect everything. In this way the base works when the PC is turned on. If I turn off the PC and the base does not work again the next time I restart it. To make the base work after restarting the PC and only by keeping it turned on from behind and the e-stop button pressed.

E-stop does not affect how the device is visible to Windows.

yes I knew this, it is strange to me that if I turn off the base and the PC the next time I restart the PC and turn on the base the latter is not detected by the TrueDrive

Just a personal anecdote as I had a similar issue just last week

  • wanted to drive a little
  • base detected and worked when turned on
  • did not connect the wheel and and the base went into sleep (I think, the dii daa duu sound)
  • turned the base off from the button and back on
  • base was not detected by TD
  • at the same time noticed my wheels battery had run out
  • I restarted my computer and the base was detected again, could not drive as my wheels battery had run out

So I had similar problem that went and stayed away (so far) with a reboot. Although I have not tested yet if it was something to do with the base going to sleep.

I’m using the newest TD test version.

My simucube 2 Pro base is no longer recognised, I have performed many tests to get it to work, but now I can no longer get it to work. I have contacted via chat on the site for a support ticket.

I dont know why you have 2 power supplyes on relative new date base purschase… you should have only one power supply with more Watts.

oh sorry, my mistake… I was thinking im reading/replying to the post owner MOGGY.

The problem cannot be understood. I switched on the PC today and the TrueDrive recognised the base. I closed TrueDrive and then updated it with the new version 2024.7. After finishing the update and starting TrueDrive, the operational status of the base occurred after about ten seconds. Previously it happened immediately.

It did a servo drive firmware update, that takes around 10 seconds.

Hi Mika…I continued to run the tests with version 2024.7, I tried turning off the base from the back button and turning off the PC. I turned the PC back on and then the base and it worked normally. I will continue to monitor the situation hoping to resolve it completely.

Hi Mika…Unfortunately, even with version 2024.7, the base continues to always have the problem. when I turn on the base, it always stays in “WAITING” mode and there is no way to make it work. I decided to install a fresh installation of windows11 but again it did not solve my problem. I tried all the usb ports, unplugged and reconnected the cables, internally checked the Estop… key nothing. What could have happened?
*** Translated with DeepL Translate: The world's most accurate translator (free version) ***