iRacing keeps crashing after start of using Simucube

I have a new Simucube 2 Pro, and its awesome :sunglasses: Only thing is, straight after I started using my Simucube 2 iRacing has started crashing every now and then. It can take 5 minutes or 30 minutes. But it does crash. I can’t do races, because obviously :joy::see_no_evil: And when it crashes I have to use the E-stop button because the wheel wants to turn to one side all by itself. This stops when I load up an iRacing session again and I go in the car. Then everything is back to normal. So it kinda seems like the FFB crashes along with the game.

I have the newest version of True Drive. Updated yesterday, but still the same issue. Also have the newest Nvidia drivers and so on. Could this be an issue with Simucube, or is this related to my PC (CPU/GPU/other drivers, etc…) and just a coincidens that this started at the same time as I started using my Simucube?

I have only tried this at iRacing. Havent been able to try other games with my Simucube yet.

It’s something on your pc causing iRacing to crash, maybe temperature ‘drivers ‘etc.

The reason that the wheel turns to one side is because it still has a ffb effect in buffer….restarting it clears the device buffer….

Most likely nothing to do with the wheel, 99.9% issue elsewhere.

Yes it actually seems like it is the Nvidia gamefilter/colourfilter that does this. Because it has not crashed yet when Im not using that. But I still have to drive the sim a bit more with the filter off before I can say this for sure. This is a bit frustrating because the original yellow tint that is in iRacing is downright AWFUL. The game looks a thousand times better with the filter on and some adjustments…

Good to hear. Yes, sometimes. NVidia experience has been known to cause some unexpected behaviours in iRacing and others.

Happy you’re back up and running :wink:

Well… It happened again today without the Nvidia Experience filter turned on. Has only happened one time though. If thats only a coincidens or if it will keep crashing, I dont know yet. But, any suggestions as to what I should try? I really have no clue because I have never had any problems at all with this PC. Not one :man_shrugging: Every driver and everything else is new and up to date and so on and so forth. I do not have ant “crap” installed anywhere and I never go to shady websites etc etc. In other words, in my mind there is no reason for this to happen unless there is some kind of PC hardware fault :flushed::confounded:

The first thing to do when you encounter games crashes is do start with the basics. Uninstall your GPU driver using DDU. Then download and install the latest GPU driver. Test to see if the issue still persists. Also remove all GPU and CPU overclocks. Also use programs like 3DMark and unigine to stress your GPU to see if that also causes a crash. This has nothing to do with your SC2

I hopped on this forum to say the same thing. I newly get crashes in iRacing after moving from a Fanatec CSL DD to an SC2. I’ve made no other changes to the system.

@StenM: Are you using VR, if yes, which headset, and do you use OpenXR or SteamVR?

1 Like

I had problems with the official NVidia driver and since I switched to NVCleanstall without geforce experience and all the bloatware everything works fine. :slight_smile:

Also just make sure that you dont have your system overclocked when you encounter crashes.
Try also to disable XMP for now to verifiy where the problem is.

2 Likes

Unfortunately, I’m having the same issue.

Had my SC2 Pro since February and never had a single issue. I recently got 13900kf and rebuilt the pc in a new case, with new installation of W11 on a brand new nVME drive. I was on W10 prior.

So, installed iRacing on the new machine, trudrive 2022.7. Copied my iRacing data from “my documents” from old computer, copied “cars” and “tracks” from old computer.

First crash was during MX-5 testing session. I restarted and ran iRacing without an issue for two AI races (24 ai cars) with no issues.

The second crash happened a day later shortly after joining a hosted session.

I have checked cpu and GPU temps right after the crashes and while GPU is a bit hot, they’re not that hot. 53 and 64C respectively. Have a 360mm AIO on CPU, the GPU is a eVGA hybrid 3090 (240mm AIO).

I’m on G2, running iRacing with OpenXR.
I have the SC2 Pro plugged in a continuous power delivery USB port, so I turn it on/off every session.

I’ll get CPU-Z and GPU-Z and will set them to log to see if there’s anything obvious.

I’m flummoxed at this point. Brand new windows, latest updates and drivers on everything. Any pointers?

Refer to my previous comment on the 17th of July

1 Like

I think it might be the bios update for the GPU. I didn’t think much of it, but when I installed the Precision X1, it installed a bios update.

I’ll downgrade it this evening when I get back from work and check.

My problem solved itself (I think…). It just suddenly stopped crashing. Have been racing for a long time now without anything happening. I belived that maybe it stopped after an Nvidia update came along. I’m not sure exactly. I also stopped using Nvidia filters and overlays btw.