Iracing crash caused the wheel rim on Simucube 2 to spin endlessly and broke my cable


today while in Iracing, the program crashed, and while it was crashing, the steering wheel span well above the 900 degree without stoping. Unfortunately my cable from my steering wheel tear appart. Is there anything I can do about this spinning problem? I’m kind of bumed as I don’t know if it could happen again and breake my steering wheel cable.

If something like this happens, it is good idea to hit the E-stop button.

Also, we are investigating how we could catch iracing crash from the firmware side - maybe full torque but no torque updates -> stop torque signal.

I did the press the E Stop button, but unfortunaly I was to slow. Does this problem occur only in Iracing, or does it also occur in other games? I can’t let this problem happen again, since the steering wheels are very expensive, and replacing the cable is a headache

Related to that question, how No Hands Detection works, I haven’t noticed it doing anything when I let wheel go in crash situation.
Have it on Low though as it was doing some unwanted stuff during normal driving otherwise, still was hoping it would catch crazy acceleration spins like that.
Is wireless wheel the only solution?

Hitting the emergency stop seems a good idea but when the servo spins out of control it’s highly unlikely that a human can react fast enough to hit it before a cable gets ripped apart. I think the initial shock when you realise this is happening causes a slight delay in your thought process.

I’ve had this happen to me recently due to a corrupted setup file in ACC. I was lucky and didn’t suffer any damage because my SRM coiled cable is super sturdy but there’s no way I would have hit the switch before the wheel had already done it’s thing.

I had this happen in Project Cars 2. Luckily I had a connector close to the wheel so it just pulled the lead out and started whipping my leg before I could hit the ES button. For me, PC2 didn’t crash but it was after a violent shunt that defeated the bump stop. Maybe that is what happened? If so increase the bump stop strength in True Drive. After I did that I had no more issues with spinning wheels.

No physical bumpstops so it will happen at every ffb Crash-hang, common in all DD I suppose, even if hitting estop, becauseit doesnt stop the Inertia of the wheel

Happened to me the very first time this week, Windows 10 update restarted my PC without permission and ffb crashed, I was racing with a plain momo wheel, no buttons

But if iRacing crashed, why didnt the SC2 bumpstop work? Isnt it on a firmware level? This seems like a SC2 bug tbh.

Dont know really, but if máx bumpstop force is 100% TD force and iR or any other software Crashes when sending 100%force, things May happen

A clipping time limit is an option but not relliable with the rotation speed of any DD wheel

I’ve had it happen quite a few times with various titles but, most of the time I can catch it in time. I now keep a few extra cables on hand so I always have a spare. At this point, I accept it as a form of preventative maintenance. :slightly_smiling_face:

Related to that, with OSW Argon in Granity we had max rpm param that was applying brake when violent spin was happening. And I was under impression that this is what Hands Off Detection does in SC2. May be it just doesn’t work but it should have caught it, methink.

I had the same thing happen to me in rF2, but I had the bumpstop strength set to 20%. Would setting the bumpstop strength to 100% solve the problem? Are there any downsides to 100% bumpstop strength?

Found it, FEV - Over Speed Fault.

yes, that is a fault limit and overcoming that needs to cycle the e-stop. It has got nothing to do with Simucube 2’s hands-off detection.

Thanks, yeah it was automatically applying e-stop in situation like OP experienced, worked rather nice TBH.
By looking at Hands Off Detection description it should accomplish similar things, wonder why it doesn’t trigger.

Hands-off safety feature
If the driver lets go of the wheel and the wheel accelerates to fast speed, Simucube by default goes automatically to safe torque mode. When driver’s hands are detected again and produce force against the wheel, the High Torque mode is smoothly reactivated (if it was active).
The sensitivity of this feature can be adjusted on the hardware tab, and it can also be turned completely off.

Yeah, we’ve noticed that the hands of detection implementation is not optimal, and there are a few ideas on how to improve this. It is a useful convenience and safety feature.

Basically, it tries to calculate whether or not the user’s hands are applying torque when the wheel speed reaches sufficient value, but for this, a quite accurate estimation of the wheel’s natural inertia is needed, so it will not work optimally for all wheel rims.


Had the same happen to us many times but only with version simucube ver 1 with Assetto Corsa. Very dangerous, so we put in a mechanical stop, then the wheel broke the mechanical stop and shaft in such a way that it would no longer rotate smoothly, installed a new motor since. This would usually happen if the wheel sits connected and turned on for long periods of time (like the weekend).

Over speed settings can help but there should be a set default of 500rpm or higher to cause e-stop condition.

Couple times it broke our motor shaft (since we have a mechanical stop). We have 7 simucube 2 (6 sport an 1 pro) wheels now and never had this happen yet.