IONI stuck in FW Upgrade mode?

Okay, so after my STM32F4 seems to have died on me (at least I think/hope it did, I don’t have the time or motivation anymore to debug that, if it’s the encoder on my Lenze that died on me it’s game over anyways) on my old Argon build I tried to get my SimuCUBE working again. Had a very old FW on it as I wasn’t able to touch my simracing setup for a while now. Downloaded the latest 1.0.30 FW, ran the auto-upgrade from the tool, all finished and now I’m stuck here and can’t connect to Granity anymore at all.


Already tried forcing the SC1 into DFU mode and re-installed the bootloader-reset-all-settings file. Re-flashed the latest firmware when asked by the SC Config Tool - same result.

I’m lost. All I want to do for over a year now is to finally get back into racing and I somehow get thrown a brick in the way wherever possible… :sob:

Sorry to bother you guys, I’m frustrated and slowly start to lose any motivation left in me…

//EDIT: just re-flashed the bootloader and I can connect via Granity as long as I don’t start up the SC1 Config Tool and do the Firmware flash. Seems to get stuck there…

Broken in 1.0.23, .24 and .25 too.

Downgrading to 0.11.2 seemed okay, trying 0.50.4d now…
… no Next button on 0.50.d…

So the latest version that somewhat works for me seems to be 0.11.2… were there changes in hardware revisions of the IONI or SC1? Seems life wants to force me to stay on a legacy system, haha… :gun:

I can also connect to Granity on FW 0.11.2 if I enable Ioni USB configuration in the SC1 tool.


Hmm, did you press the Enable IONI USB Configuration in the Simucube Configuration Tool before you tried Granity?

Thank you for the quick reply, appreciate it!

Yes, tried that.

TL;DR from the above: I only have this behaviour when on a FW > 0.11.2 (this is also the FW version I had on it before upgrading). Untested at the time though as I had trouble sourcing a suitable PSU for the Lenze motor…

On FW > 0.11.2 I also get “Waiting for drive to get ready” in the SC Config Tool and sometimes a “FW update failed, please restart”.

I wanted to gradually upgrade from 0.11.2 as a next step, but even in the “fixed” version (0.50.4d) the Next and Close buttons are missing for me.

GC 1.7.18 should be the FW that ships with 1.0.30, correct?

Yes, 10718 firmware ships with the latest released firmware.

The issues you are having are really strange. I haven’t come up with explanation right away, and it could be a lengthy period of time before we get around to having a look at Simucube 1 stuff again - that is, porting new features that are coming to Simucube 2.

Don’t waste any time troubleshooting / looking into this at all please if this is an isolated incident.

I just wanted to know if this is something well known that’s fixable by myself (user error). I already more than appreciate your quick response and don’t want to waste your time any further!

Keep up the good stuff on the SC2, maybe one day I’ll actually be lucky enough to drive one of those beasts :muscle: and don’t have to resort to this kind of setup:


hmm, is it at all possible, that you would have one of our very earliest prototype units? Whats the revision number on the unit? 1r00 something?

I think it should be a production unit already: 1r004

If I remember correctly I got this one after release. Not sure if I actually ever had a prototype at some point.

Sorry for the bad shot, can’t get it to focus.

yeah, 1r004 is a production unit, so no dice there in trying to find the fault… :thinking:

I owe some :beer: s to @phillip.vanrensburg - had a chat with Beano and the following did the trick:

  • flash bootloader-reset from 0.11.1
  • flash fw 0.11.2
  • flash fw 0.50.4.c (.d doesn’t have any buttons for me)
  • flash fw 10.0.30 / latest

@Mika no idea what was going on here, but at least it’s solved now. I’ll mark this answer as solution.

All working now. Thank you guys!

More complicated than it should have been for sure, and very difficult to point a finger where it went wrong! Although, there is a report that some buttons also sometimes also missing from official 1.0.30 release, that is really a problem…

I hope we can have a beer after this covid stuff is over.

Absolutely! Been waiting on that opportunity for way too long now… :mask: :airplane: :beers:

I don’t have anything with buttons right now, but what are we talking about? Wireless or expansion port? Maybe I can at least have an eye open for things when I get my stuff together…

I was referring to the next/cancel -buttons in the firmware update prompt :slight_smile: But wait till you see the number of buttons and other options in future wireless wheels. :wink:

And usage of the expansion ports on Simucube can always be discussed…

1 Like

Hi Mika,
This is same case and the way I fixed it for one of Joe Sullivan’s mates in the USA some months ago, if you remember. I thought Bernhard’s case looked similar as what I found fixing that one, so it was a simple case of replicating what I did there.

But yes, I have seen a couple of these stubborn Simucubes now from r1004 batch…just glad Bernhard is sorted for a while longer!

Now to convince him to do a vertical sim-rig :smiley:

1 Like

Yes Mika,

As Beano mentioned I was trying to help a guy who had a very stubborn SC1.
I tried everything in my tool bag unsuccessfully, and my bag is pretty big! LOL

Beano got the guy squared away. I don’t remember who it was. I don’t think it was one of my old customers.

@Joe: Ha, found it, it was Steven Brown -> Simucube 1 connect to software

Had to use the same 11.1 as what Bernhard did last night…anyway, now we know that version can revive a stubborn-to-flash SC1.

@ Ahh good find.

Could you send me the 11.1 file please?
I seem to have 11.0 and 11.2

It is good to see Bernhard back in the world! It has been along time since the early Argon builds!
Many of the new Pups on board have no idea what we used to have to go thru to get a DD wheel built and up and running. :slight_smile:

Be safe in OZ We are FREEZING in Washington DC USA!!!

Ha, all good! I don’t have the file here on my iPad, but grab it here:

That’s the version I used, should be good to resolve any issues you may have in future.

Sweating this side, been a hot week, with even warmer weekend-weather forecasted…so just the opposite from you! Keep warm and stay safe, Joe, catch ya soon!

PS: Very happy we can keep Bernhard here in the rabbit-hole with us a bit longer! He got me started on this whole DD thing back in 2014 with his Rs-485 based interface …it has been an interesting journey for sure!

Maybe this “process” should be added in the Wiki troubleshooting section of the SC1.

I’m wondering what causes the Buttons to be missing in the interface… if this is somehow coupled to an internal state of the SC1 it might give some insight into what went wrong as they seem to be missing in different versions (it was missing in the 50.4d for me which supposedly contains a fix according to changelogs but they showed up on the 50.4c - at least the 3rd time around, didn’t try 50.4d the 3rd time and didn’t try 50.4c the first 2 times).

PS: to close the circle, we’re freezing here at -10°C in Austria, but I’m sure it’s even colder in Finland.

I won’t ever walk away from this, just because I’m not actively racing doesn’t mean I’m gone in any form or shape, my mind is and always will be here :wink:

And none of this journey would have been possible if it wasn’t for the Argon’s OpenSource FW and above and beyond initial support by @Tero - it’s one of these once-in-a-lifetime things where the dominos just fall into place naturally. :partying_face: