Ioni - Simucube 1 not recognized in either Simucube Conf Tool or Granity


After having my Simucube turned off for a couple of days, i came back to start it up today. It doesnt seem like it is recognized in neither Simucube configuration tool (SCT) nor Granite software.

I’ve tried switching computer, Switching USB cables, reinstalling both granite and SCT. Nothing seems to be working.

Ive tried setting the DIP switches in all different configurations.
Granite doesnt find any devices at all (though the USB interface is visible).
When i have DDU Mode off and the “normal” DIP in different positions, i seem to get alot of unknown devices when i search for it using granite.

Does anyone have any idea what might be wrong?

im getting SSSL Blinks on the board, which indicates “Unkown fault, possibly motor configuration”

Best Regards
Oskar Wallin

Have you tried with e-stop pressed in at start, does that make any difference?

Yep, Always start with Estop. The motor beeps once i release it… so something is working atleast

Yes, but can you connect to the drive when the e-stop is pressed at start (never releasing it before connecting)?

Which firmware version were you running?

Thanks for the fast reply.

Nope, nothing is detected no matter if i use the E-stop or not at startup.

Im not sure what firmware version (cant check it, since granite doesnt find the device).
Updated it a month ago though to the latest available.


It does not seem like the X3 Connection is working at all.
Nothing pops up in device manager (X4 does).

I was gonna try reflashing the mainboard, but since the X3 Connection seems to be gone, that looks like a hard task.

Any ideas on how to fix a broken USB interface?

Using MMOs tool aswell as DFSedemo software according to the wiki, but no luck and no connection.

The USB port is directly wired to the STM32F407VE microcontroller on the Simucube PCB. Most likely the ESD protection diodes on the PCB have burned or the processor has died for some reason. There is no easy way to replace the processor.

New main board it is then!


New Mainboard Solved it!

Got a reflowstation at work, Maybe worth a try resoldering another STM32F407VE on there?

yes, that will be possible. Empty STM32 will show up as in DFU mode. But inspect the ESD protection diodes as well.