IONI 1.7.4/1.7.5 Center calibration issue 5º left displaced

MiGE 130ST-M15015 with Sin / Cos encode
IoniProHC 25A
PSU 480W

I have this problem with IONI 1.7.4/1.7.5 (not with 1.7.2)
I have this problem with all simcube versions I tried

After calibrates it, center point is displaced 4-5º on the left.

I made this sort video for you can see the issue.

As you see, after calibration phase, I don’t move the wheel and the center point is not correct.
Same issue in manual or automatic.


This is more likely a bug in the SimuCUBE firmware. I’ve moved your post. This issue will get worked on for the next release.

0.9.7 and latest ioni i think no problem like that.

@Onazol: Can you try following. Do not touch the wheel at all at any point.

  1. do the wizard, but when the wheel phases and beebs, do touch the wheel at all. Set center at that point.
  2. Do not touch the wheel at all.
  3. Enable IONI USB Configuration Mode
  4. Go to Granity, connect to drive. What does the Position Feedback value show on the Testing tab?

OKA, for your informatión…

I have this issue with:
IONI 1.7.4/1.7.5
Simcube 0.9.7/0.9.8/0.9.9

All work perfect with:
IONI 1.7.2
Simcube 0.9.7/0.9.8 (I can’t test with 0.9.9 cause of IONI auto update to 1.7.5)

I’ll wait for new versión, thanks

OK, let me try it …

Even simplified test would be to just restart drive in Granity, then not touch the wheel, and see if the Position Feedback value would be off by the 4-5 degrees amount.

I can say that I just did that at my end, without touching the wheel, and my wheel was off-center. Going to granity, still without moving the wheel, the position feedback value was -13700 which exactly corresponds to the amount my center was off.

So, this is a IONI firmware bug. Thanks for reporting! I will let @Tero know about this.

I start from 0.9.7/1.7.2

Dont touch the wheel any time

I update to 0.9.9/1.7.9

Virtual Center point in simcube screen is equal to real wheel

This is Granite values:

But, when I restart my PC, and switch off electric power, the issue is again

I’m goint to restart now and send you again screen capture after that.

This is after restart all, switch off electric.

Didn’t touch the wheell any time

We have released IONI firmware 1.7.6 which fixes this issue.

It will be included and automatically updated in the next SimuCUBE firmware release, but you can manually update via Granity if this issue affects you.


no problem with this version 1.7.6 on raceroom and dirt rally
thank you

It’s works, thx for the fast response