I have an issue and I'm hoping it's not hardware related


#1

I just noticed this last week when I went to use my rig for the first time in a while (I always leave the Simucube off when not in use and the software stays closed as well). I booted it up last night and it ran the phase test and beeped like usual but I noticed that i can feel a very mild humming/buzzing feeling coming through the wheel before I even opened the software. The wheel also has some slight resistance like I have a profile loaded, which I didn’t. Then once I opened the Simucube software it was very ‘laggy’ and almost unresponsive; it didn’t recognize the hardware for a minute or two. I tried to click my Assetto Corsa profile and it wouldn’t do anything so I walked away for a couple minutes. Once I came back it had finally selected and loaded it, but once I went in-game it was obvious it wasn’t the correct profile and the wheel kept going dead as well while driving.

I’ve had this for over a year and nothing has changed as far as how I have it hooked up or anything else. Minus some W10 updates over the course of the year as well as changing all the storage in my PC to SSDs but it has worked since then up until last week.

Oh yeah, as a last resort I updated the Simucube software to the latest beta last night and it did the same thing except it took even longer for it to recognize and find the hardware. It wouldn’t respond at all when I tried to select a profile. I’m hoping I don’t now own a $1500 paper weight :frowning:


#2

First things you could try, is another USB port on the computer, and also another USB cable. It does sound like some type of a connectivity issue.


#3

I’ll try switching ports first. I do have everything on my rig connected to a powered USB hub as the PC is too far away but I haven’t had any issues with it so far.


#4

Could you atleast try it without the hub?


#5

I can I guess but I’ll have to relocate the PC temporarily. I do have a 10 foot USB extension cable I can try too.


#6

You could try it but i think it is a bit long.


#7

Moved the Simucube USB to a different port on my powered hub and the issue seems to be fixed so far. Crazy that an input issue can cause the software to bug out like that.