I can't seem to remove the torque ripple in Granity for MiGE 130ST M15015 BiSS-C 22 bit encoder

Coil Resistance and Inductance are measured, and they are close to the data the seller provided.

I cannot find the single turn and multi turn resolutions for the biss-c 22 bit encoder. I am using the Yu-heng JKD-4-22PF-G05BL-B-0.3m encoder.

I already tried torque ripple and cogging compensation, but nothing seems to affect the torque ripple. I hit apply settings and tried checking auto apply, still nothing noticeable changes. Same for changing Torque Bandwidth Limit.

Torque ripple occurs both in games and when using the TSP1.

I feel a total of 8 bumps / rev when powered, and 72 / rev when powered off


The fix was checking the box “[FBI] Invert Feedback Direction”.


When setting up servo applications, one should always test the wiring and encoder direction before anything else. If the torque mode doesn’t work nothing else is not going to work.


Kind regards, Esa

Also, in Simucube use case, there is typically just one combination of FBI (invert feedback) and AXI (invert axis direction) parameters that produce correct torque AND the wheel rotates in correct way on screen.

Thank you, Esa, for the instructions. I was lost for so long and read so many wiki pages, but never got to that page.

Thank you, Mika, for the additional input. I had to reference someone else’s .drc I found on the forum to realize this too