Help with new simucube setup

I have a question regarding simucube regarding its setup. I,ve done all the wiring at the simucube and the psu but when right after i connected the psu to the wall the big square white piece i think it is the resistor near the ioni drive started smelling like burning and got pretty hot (i touched it) so i disconnected the psu from the wall, just in case, the board leds were flashing but didnt connect the usb. I checked the psu and were at more than 49 volts, now i have regulated it, could this be the issue?

My hardware configuration:
-ioni 18a early bird
-small mige
-Dont know firmware version
-(other details)

Problems arise when:
-soon after connecting the wall plug.

Most likely your PSU is giving much more than 48 volts. For initial setup, you can disconnect the motor, measure the PSU voltage with a multimeter, and adjust it close to 48.0 V.

Then you can connect SimuCUBE on to your system. Connect to drive via Granity and set FOV limit to, for example, 50 V.

ok now its starting without the smell after regulating the psu, the thing is now i have only wired the psu and the usb to the motherboard is an asus p8z77 v pro, i connected through usb from x4 port to the motherboard i hear the windows usb detected sound but it is not recognizing/installing the device.

led three on simucube board is constant green and led 4 5 and 6 are intermemitently lighting in green red green, the ioni leds are intermitently lighting too.

solved by myself partially hahaha, i needed an older version of granity to update the ioni drive, left this open just in case :smiley:

ok couldnt get the simucube to be recognized through the x3 usb, i can access through x4 to granity and upgraded the ioni firmware to 1.6.1 but using x3 usb does nothing windows dont recognize the device, the 3 led is on and 4 5 6 leds are blinking.

Have you installed any firmware to your SimuCUBE? Are you planning to install MMOS or our beta firmware?

I did not installed any firmware yet, i plan to install the beta firmware, but when connecting at x3 usb the device is not available in windows.

There should be some a Stm32 device bootloader visible in device manager.

You can use the dip switch method in any case, as explained here:

Hello, I have purchased a unit of SimuCUBE and IONI Pro from Granite Devices and a small mige 130ST-M10010 with a encoder Sincos from Tomo.

I have not yet configured or installed anything software, bootloader or firmware.

Can you confirm that steps to follow are these:

1 - Connect SimuCUBE to the computer through the USB / HID port (x3)
2 - Run the SimuCUBE configuration tool .exe and press the Update firmware button. This will install the bootloader, the SimuCUBE firmware and IONI firmware? (I read the guide but it is not clear to me because of my bad English)
3 - Press "Configure motor, encoder and center point and load a drc file provided by Tomo for my motor and psu
4 - Set up a profile and enjoy

In all this process how should the e-stop button be, open or closed?

Sorry for my english and thanks


In step 2, the bootloader must be installed by using DfuSeDemo that is available from ST Microelectronics website. After it has been installed, you can use SimuCUBE Configuration Tool to update the firmware.

Thanks, I did the steps and it worked perfect.
Great job this firmware Mika
I have another problem and I read in a post that also happened to you.
My wireless logitech mouse and keypad are disconnectet…
Did you find the solution?

I found that very old ones that use 27 MHz frequency don’t work, but modern ones that use 2.4 GHz do. This is due to radio frequency interference.

What exact model is your mouse and keyboard? An FCC acceptance ID would also be helpful.

Also, USB 3 ports are known to emit too much noise at 2.4 GHz frequency band for any 2.4 GHz bluetooth or proprietary (Logitech) receivers to work. There is even an IEEE paper about this.

Solution is to use a short USB 2 extension cord for the wireless receivers.