Help to start SimuCUBE

I will get back to you when I have enough bandwidth to view that video with good resolution.

Try swapping to the other Usb port and install the boot loader then open the simucube config software. Granity wont work until that is done and the toggle switched or you install MMOS

I have EXACTLY the same issue. I was also about to upload a video like you, so I would be very pleased with a solution or any guidance.

Very recently bought my stuff (directly from Granite Devices). Got everything connected, I have ground connection, but for the rest exactly the same thing as you. I also have this problem: The Simplemotion V2 connection does not show up. Only a Simple Motion Serial and an other kind of SimpleMotion connection. When trying to connect, both give the empty screen like visible in the footage.

@ Troyau. This is opening Granite, using the X4 port as described in the manual. It doesnt describe that any bootloader should be installed for that. The simucube bootloader is a totally different thing right? Moreover, in the user manual of SimuCUBE firmware is stated as initial step:
The following settings must be done, before updating to SimuCUBE firmware. 1) Check in Granity that SMO value (SM Bus Address Offset), found on the Goals tab, is 0.

But we cant even connect to Granity make this sure.

Maybe I an not understanding this correctly, but I hope somebody can help.

edit: I have installed the simucube bootloader, simucube was installed correctly. But when entering the motor settings, there are also problems. When trying to load in the motor settings I get an error. Either by letting simucube connect to IONI I get or by loading in a DRC file that I have obtained. It gives the message: 'error motor did not initialize in 30 seconds. Probable cause: wrong settings.
Also After the bootloader install, I can still not connect in granity. Not using the x4 or the x3 port.

When Simucube firmware is already installed you need to ‚Enable IONI USB configuration‘ (can be found in Advanced tab in Simucube configuration tool) to be able to connect using granity.

Nope. I have tried that. It doesnt work unfortunately. I tried that using the X3 and the X4 ports both.

These steps are usually required only if user is migrating from the old MMOS firmware, which didn’t connect to the drive at all, and thus any bus address offset worked fine.

Two remarks from myside.

  1. The supply cables are far to thin for the current that is flowing during operation, may be they even prevent the motor from initializing
  2. I‘m missing the connection of the powersupplies case to the second gnd pin of the simucube powersupply connector - of course mostly needed when mounted in a cade to avoid electrical hazard.

I agree, the wires are too thin.

The video is too poor resolution to actually see whats going on, but I would update the drivers for the FTDI chip:

Thanks for thinking with me guys, I really appreciate that. :slight_smile:

In my setup I do have the ‘second’ ground cable from the casing of the psu. The wires are 1.5 mm solid copper cables. Which should be enough.

I also have re-installed the drivers already. No result.
I find it very strange that it doesn’t work. I am going to redo the whole bootloader flashing process and I will try it on a different computer. Hopefully that works.

Some additional side notes that I noticed/did. Due to my lack of knowledge of the internals I can’t say if these notions are important or not.

  • psu (mw sdr 480) outputs 47.9 volts.

  • the ioni pro hc flashes green Long Long Short

  • the motor does feel a heavier/makes resistance when the power is turned on.

  • I have not touched the grey resistor (I think it is) block that is plugged in two terminals on the long side (‘backside’ ) of the simucube, close to the hv+, gnd, gnd terminal.

  • emergency stop is released

  • ioni pro hc is correctly placed

  • when I turn the simucube on from the X4 output, I hear a ‘ba-boop’ sound in windows, but does not show its installing firmware or showing the name of a device. Using the X3 output, it does show the device right below in wibdows after connecting.

  • After Installing the simucube bootloader, it updated and succeeded.

  • In the advanced tab I read that all stuff is up to date (ill report the exact numbers later on)

  • Above in SimuCUBE it reads that hardware is not confugured, Unknown status of e-stop.

  • possibly most important. When loading the motor settings either by a drc or using the default (connecting to ioni) above in the SimuCUBE status it showed in red: FOV Over Voltage Fault Threshold has to be set to minimum of 102% of the supply voltage But how do I change this? As I cant access granity?

The strange thing is that, even if I wanted to install MMos, it would be impossible since I can’t access the servo in granite isn’t it?

I will post a picture of my setup when I’m back home after Easter. Maybe you guys see something that I missed. But any response in the mean time is more than welcome.

What happens when E-stop is turned on/pressed?

Also turn simucube off/on with E-stop active.

The error code from IONI is also stating configuration issues as far as I have seen on the wiki.

That hardware issue is the LLS sequence of the orange led. I have the green LLS, which means “permanent stop” as far as I can see.

With the E-stop pressed in (on) the ioni pro hc starts to blink a red light. I’m now sitting in the train, and cant remembrer the sequence anymore, but I can test it when I’m back.

Otherwise all problems that I have are tested with both the e-stop released and activated

According to this page

Permanent Stop can be caused by parametrization issues.

Okay, that’s interesting. Goes true when changing certain parameters or if initialization fails.

Solution: try restarting to check if it clears. Else check parametrization or usage errors.

Well, I have restarted the drive many times and it remained.

What can I do to solve this? I dont really understand what it means and how I should check/resolve it.

I’ve PM’ed @TheMarshal with a support option/offer. Hopefully he sees it soon.

I updated the line.

If you are already using Simucube firmware, did you ‚Enable IONI USB configuration‘ in the configuration tool, as explained a fee posts earlier? If not you cannot connect in granity.

I change the wires and install the driver, is it the same driver as the instruction in wiki? but still not able to connect ioni drive via granity.

@chichi No, I’m not yet install any firmware, this is a brand new simcube+ioni pro HC and I’m trying to set them up.

I followed the instruction by connect usb via X4 and been trying to do a motor configuration via granity for the first time. But stuck, as there was no drive to select after I click the “connect to drive” in granity.

I tried to check the troubleshooting, but there is no information related to simcube. I really do not know what to do further to set it up.

Is there any troubleshooting I should do? it seem like I have a very same problem with @TheMarshal also the LED blinking also same.

Alright, tonight I had the time to re-do this all and I fixed it. @rung168 this may be a key to your problems as well.
I tried quite a few other things before it finally worked. Here I describe what finally worked.

I used a different pc, set-up the simucube in DFU mode (case c). I also installed the simple motion v2 VCP driver from the wiki.
After connecting with the X3 port, the pc recognized the STM device. However in device manager it appeared with the yellow triangle with an exclamation mark.

The first time I didn’t check this, but defusedemo worked and uploaded the dfu that time. But still I think it may have corrupted (a part of) the bootloader.

This time I manually installed the STM devices driver as shown in the troubleshooter of the simucube user manual.
I ran defusedemo in administrator mode and uploaded the file as instructed by the manual.

Afterwards I switched the DFU switch on the board back into run mode and restarted it. Connected to simucube software. Also this time I turned on the enable ioni feature in the advanced tab. Changed the connector to the X4 port. Still the simple motion bus names had not changed, however this time I WAS able to connect to the servo.

I uploaded the motor configuration file, applied it and restarted granity.

I reconnected with the X3 port again, opened simucube software and turned the ioni feature off again. Restarted the simucube firmware again and this time I was able to successfully initialize the motor. I used the default method to initialize (connect to ioni/the one on top).

Everything worked. All errors were gone. I was happy as a kid.

In summary: put your device in manual DFU mode, do the hole stuff again and don’t forget to manually install the STM driver before you run defusedemo.
I think this has caused all the problems in some strange way. Although, with the drivers not installed, I would expect that defusedemo would give an error if one would try to upload the bootloader. However, maybe it does not and the installer just forces the bootloader in the simucube, thereby corrupting it in some way.
Maybe this is something that should be clarified in the manual. I would suggest to describe that people should check the device manager, and if necessary install the driver manually already in the installation steps and not at the end in the troubleshooter. Furthermore run all applications in administrator mode.

Thank you, I try to follow you.