Help - SimuCUBE all grayed out and device manager says issue

MY friend wanted to use his Simucube for the first time in a few months tonight and ran into issues.
Simucube starts up and phases but config tool is all grayed out.

Windows device manager reports error in “other devices” saying “Base System Device”.
Windows cannot find a driver for base system device

Tried to reinstall DFUSE and same issue.

Tried to update Simucube Firmware but says can’t communicate.
Granity can’t connect (both USB devices are installed) - it shows the COM 3 Simple Motion V2 in the drop down but when connect and it searches for devices nothing comes up?
Got a feeling this has to do with Windows, but could it be a burned board? Lights are on on the board and it has power?
Any ideas?


Turns out it was a defective USB cable, so Simucube config tool seems to be working ok.
HOWEVER, in device manager the same error regarding base system device?

Does the Base system device disappear when you turn off the SimuCUBE? I believe it is not related to SimuCUBE at all.

I’ve asked my friend to report back - will update you when I know.
It sounds more like a Windows issue to me to be honest.

So, it turned out to be a Thunderbolt driver issue.
Not sure why and how this happened as my friend uses Win 10 Pro V1607 and blocks all driver updates from Microsoft.
Figured it out via registry I believe.