Granity, no devices found when pressing 'connect to drive' (and possible future questions)


#1

Hi,

I just finished connecting my Simucube. So now I connected the USB between pc and x4 connector, manually installed the FT230x driver because Windows didn’t, and downloaded Granity.
Now I’m pressing ‘connect to drive’ in the Granity software, a list of connected drives comes up, but unfortunately the list turns up empty. What can I do to get my Simucube to show up in that list? Are there any steps I can follow to troubleshoot this? I already tried 2 different USB cables.

Edit: These are the steps I’m following, stuck at 9. now (also couldn’t find 8.):
https://granitedevices.com/wiki/Configuring_IONI_drive_in_SimuCUBE


#2

Have you installed the Simucube firmware yet? Is this a DIY build, or a ready-made kit?


#3

https://granitedevices.com/wiki/SimuCUBE_firmware_releases


#4

This is a DIY build.

So I should install the Simucube firmware first? I didnt do that yet.
Are the steps that I followed outdated?


#5

Ok, then you definitively should have the IONI drive visible in Granity. Do you have IONI Pro or Pro HC?


#6

I have the Ioni Pro. Not the HC model.


#7

@Mika So any clue what I can do to get the Ioni to show up? Or is this something you have to look into first?


#8

I think you should proceed to installing Simucube firmware and go from there. If it does not connect to the IONI either, we’ll know there is an issue.


#9

Thanks for your quick response again.

I gave it a try, but I get nothing in DFUse Demo and nothing in the Simucube software.

In device manager I only get “USB Serial Port (COM6)” under the ‘Ports’ tab when I plug in the USB from the X4 port. Is that correct?


#10

Do you have x3 usb connected?


#11

I must’ve read some old info. I thought it was only necessary to connect one of the USB’s at a time. I have connected them both now and got a bit further.

Managed to finish the bootloader steps and installed the Simucube firmware. Now I’m stuck at “Select motor configuration”. I tried the option to use the IONI configuration as-is, but it fails phasing then. Is there anywhere I can find a DRC file for the small Mige with Biss-C encoder?


#12

Numerous forums, iRacing forum at least. I do not have the files at hand right now.


#13

I’ll google some more then. Thanks a lot for your help!


#14

Biss-C encoder DRC files from SimRacingBay here


#15

Thanks, looks like I’m up and running. Next step is to finish the physical build and mount the thing to my rig.


#16

Happy New Year!

Even though I’m up and running through the Simucube software now I still get nothing showing up in Granity. @Mika do you have any ideas what I can do about this? In the short term it’s probably not a big issue, but it’d be nice if I can use Granity if I’ll ever need it in the future. Right now I’m using a DRC file from SimRacingBay, and I can’t change the max current myself (outside of the % slider in Simucube) for example.

I also have a different question. I’m going to build my own buttonplate. Does it matter which groundpin I connect the buttons to? Can I connect for example button 9 between pin 2 of X12-lower and pin 8 (ground) of X12-upper? This would save a wire on my coiled cable as I’d only need 1 wire for ground instead of 2, which means I can add another button to my buttonplate.


#17

You must click “Enable IONI USB Configuration” in the advanced tab to access Granity when using Simucube firmware. But you should not have any need to do so if the system is now working.

Yes, the grounds are connected internally so only one of them is required on the X12 inputs.


#18

That was the trick, IONI is recognized by Granity now. I know I might never need it, but it’s reasuring to know it works at least and that I don’t have some kind of weird issue with my Simucube which might bite me in the future.

Thanks again for your help.