Firmware 2021.4_4 caused USB issues with SimuCube 2 Pro

I don’t want to cause a panic (but I just experienced a panic for the last hour myself), but I just had a terrible experience with the new firmware that is included in TrueDrive 2021.4_4 that was just released. I fired it up, installed the new firmware and everything went well with the update. Then . . . TrueDrive wouldn’t recognize my wheel even though Windows made the normal USB sound, and the SimuCube made a normal beep.

It seems like Windows added a new “HID-compliant game controller” under Device Manager each time I turned it on, but Simucube 2 Pro didn’t show up under USB Game Controllers and nothing in TrueDrive. I tried everything, deleted USB Root Hubs, different USB plugs, reboots, tried to downgrade firmware, EVERYTHING. Finally, went and got my laptop and plugged in SimuCube 2 to that and it detected and TrueDrive worked fine. I quickly downgraded the firmware to 2021.1 and then plugged it back into my main sim rig. EVERYTHING worked fine! Crisis averted. It did have a problem recognizing the USB device and I had to delete it from Device Manager, but it found it after that.

Now I’m afraid to update the firmware. . . any suggestions? I’m really looking forward to the new cloud capabilities, etc. but don’t have a backup servo so can’t afford to knock myself out by experimenting with firmware updates again :frowning:

1 Like

I think you didn‘t break your Servo, when it was detected instand on your laptop. Sounds more like your racing PC has some USB issues. What platform are you on, AMD or Intel. There are already threads were users has reported similar issues on AMD platforms.

The 2021.1 release had USB Composite Device added, with composite game controller + serial port setup. The firmware had a bug in it that caused the device not to be detected anymore after some USB events, so we reverted back to how it was before, in 2020.10 release. Maybe Windows has some issues in going back - but we have not seen this behavior previously.

I changed the subject to be a little less scary. . . but the bottom line was that it worked great (on firmware included with TrueDrive 2021.1) and then when I upgraded the firmware, my servo wasn’t recognized. It took me an hour and a half to kind of work through a checklist to fix it, but I’m imagining someone who isn’t a geek effectively having an unusuable servo on their hands.

I’m running an Intel i7-10700K on an MSI MAG Z490 Tomahawk. I’m not opposed to reinstalling Windows 10 (not ideal, but if I have to), it’s a fairly clean install that is about 12 months old and PC is only used for iRacing and nothing else.

I suspect that 2021.4_4 is still suffering from that USB issue from 2021.1.
I have started seeing my SC2 Pro in Disconnected status after starting TD, the only thing to clear it up is to reboot PC. Never seen that with 2020.10.
Z390 Intel system.

Lets not spread any misinformation.

I just diffed the whole USB code from the latest release against 2020.10. No differences were found, as expected.

Happened like 3 times already, this is user experience, not misinformation.
I do not discount that some additional factors like Window update were added to the mix, not necessarily FW USB changes. I will revert back to 2020.10 next time this happened and will report if issue gets fixed.
As a side note, after these failures I could see some hidden usb devices in Device manager with “failed to initialize” label.


These might be leftovers from the issues in the 2021.1 firmware. In general, Windows tries to cache a hierarchy of the connected USB devices and instead of installing them again when the hierarchy changes, it will try to migrate the devices to different USB ports. The 2021.1 firmware had a Composite Device with HID (game controller) interface and a USB serial port, and it looks like Windows does migrate the previous game controller (on its own) to the composite device, but something strange happens when it goes the other way like going back to non-composite device. Deleting all hidden game controllers, serial ports and composite devices when Simucube is not turned on, might clear any issues with Windows caching things…

1 Like