F1 2019 help needed


#1

Hey guys has anyone got the f1 2019 or 2018 to work it’s a nightmare and can’t seem to get it to work any help would be greatly appreciated


#2

Hi,
Anyone found something to make it work?
I was trying vjoy and axis remaper but no luck…

@Mika how can it be fixed?

Regards
Bazz


#3

Hi Bazz my sc2 pro is working with F1 2019 and F1 2018 also.


#4

How? :slight_smile: I can’t get F2019 to see steering axis from my SC2 Pro…


#5

First setting the right steering range you need in TD software, go to F1 2019 setting put your wheel centre.Then click left and route the wheel to left to deep (touch bumpstop)and centre it again.


If still can’t send me your email I make a shot video to show you.


#6

Hmm, thank you, I know how to do that. I’ve done this in same way but maybe I didn’t center the wheel after hitting bumbstops… will check :slight_smile:


#7

No joy. Still I can’t get any reaction from the game to steering left and right :confused:


#8

I tried to ask to this guy but he never reply me :(.
www.youtu.be/cJH0nwHFQi8?t=19


#9

Hi I have make a short video ,hope can help you guys https://youtu.be/SHEiBCQxynw. Sorry for the bad quality video.


#10

Thank you Sir. I’ve done this in the same way as you did in video but game is not detecting any movement.
I’m on fresh fw and TD software and up to date game and win10.

Here’s my situation:


#11

Bit of a longshot but might be worth a try.

Could you increase the amount of steering lock in TD to something like 720 so that you can get more of a full revolution on the wheel, just whilst you are trying to assign the left and right inputs.

I’m just wondering if the game needs to see more of an input to recognise the SC2.


#12

Good tip. I know in raceroom (and also maybe rfactor2) you need to turn full turns left & right for the steering input to register.

Also was thinking if you had another wheel in the game before (Logitech/TM)? Dont have this game so dont know if there is a old “wheel.cfg” file you can delete.


#13

Game is fresh, save game directory deleted with all hw settings, I’ve tried 900’ - same thing.
Windows game control panel and DIview are detecting movement, game is not :confused:


#14

You have tried different USB ports? front back, USB2/3 etc?


#15

Success! :slight_smile:

I’ve changed usb port from 3.0 to 2.0 but still no joy. Then I moved plug back from usb2.0 to usb3.0 on which it was connected earlier and changed steering range in TD to 320’ as I was tired of swinging it back and forth on 900’. And it worked!
Honestly I don’t have a single clue how… Maybe connecting it in different hub on mainboard cleared some hw id’s in windows… anyway - it’s working now :slight_smile:

Thanks @ylleeason @Boska @Albert_Brennan and @EsxPaul :sunglasses: cheers!


Not seeing the Simucube 2 in rfactor2
#16

Great news! USB can be a real pain in the @ss sometimes.


#17

Great job, enjoy your game:sunglasses: