Extreme Clipping and Force Feedback Issues In Every Game except WRC9

  1. Everything was working fine.

  2. Installed WRC 9 and got it working with my SC2 Pro and my existing GT Wheel (using my Dirt 3 Truedrive profile).

  3. Got a new Ascher Racing B16M-SC wheel. Works great, using the exact same Dirt 3 Truedrive profile.

  4. Played it for a few days, no issues.

  5. Excited to try my new Ascher wheel on other games I boot up Dirt 3 (using the exact same Truedrive profile that I was using in WRC 9). I did not change any settings in Dirt 3. EXTREME clipping issues. Basically; (unless the car is standing still), if I accelerate and move the wheel, it clips. Going about 10km/h in the game has extreme clipping and the wheel is ridiculously waaaaaay too hard to turn.

  6. Boot up Assetta Corsa. Change the Truedrive profile to my existing AC profile I already had saved. Exact same extreme clipping (basically every time I turn the wheel) and massive amounts of force feedback. Not at all what it used to be like.

  7. Boot up Dirt Rally 2. Exact same problems.

  8. Ok, maybe something is weird with the Ascher wheel, so I swap it with my GT wheel. Exact same problems with the exact same games. (None of these problems previously existed.)

  9. I’m going to try WRC9 again to see what happens. Works perfectly with the GT wheel. (!?) Swap the wheel with new Ascher; works perfectly. (!?!?!?!?!?!?!?!?)

  10. Go back and try all the other games. All have the clipping and feedback problems.

  11. Try WRC9. Works perfectly.

I’m completely perplexed…it seems that nothing except WRC9 works now.
Anyone have any ideas?

Post a screenshot of your true drive settings and in game settings

It’s happening on every profile for every game. I even download about 6 online profiles (for various games) from True Drive today and same problem with all of them.

I just downloaded the latest firmware and True Drive software.

That being said, I have seemed to figured out what the problem is. Regardless of the setting in True Drive, the Center Spring strength always seems to be at full strength. I can feel no difference between 0 and 100 in the setting while playing a game. This seems to be why every time I turn the wheel, once it gets out of the center deadzone in a game, I get clipping. This also seems to make sense that the wheel is crazy hard to turn even in a straight away doing 5km/h, the Center Spring strength is constantly trying to pull it back.
I have reduced a bunch of games to having zero center deadzone and it helps immensely, but obviously this is not ideal.

So, I guess the questions are;
How do I reduce the Center Spring strength, when True Drive seems to be having no effect on it?
And why on earth did this all of sudden start happening after playing WRC9, which is not effected by it?

This sounds very strange. Games do not usually use DirectInput Spring effect - only game I know to use it, is the European / American Truck Simulator games.

No simulator titles should have non-zero center deadzone for steering.

ams2 and pcars2 do enable spring di effect

@Mika DI spring effects are not perfect on TD, and more of them. Friction is broken too like Centering spring effects not active when game starts.
And for your info, not only sims are played with our Simucube bases, virtual Drivers don’t just consume simulators.
Emulators, arcade games, old games, all of them uses DI effects to some extent.

Please take care of DI effects before jumping in another firmware reiteration.

1 Like

So I am having to redo all my settings in all my games due to the centering issue above. I have also tried out some new games and seem to have an issue with the new version of True Drive;

Am I totally blind, or is there now no way to copy a profile in True Drive?
For example, if I had a profile for WRC 9 and wanted to use it for WRC 10 I have now have to start from scratch on a new profile. In the older version, I could just copy the old profile, rename it and tweak it. I thought maybe the settings from the last active profile would just be left “untouched” when I create a new profile, but alas, they change. (I have no idea why). This seems like a step backwards in terms of software development and can not understand why a simple copy function would be removed…?

Additionally, I noticed you can not rename a profile anymore. Why not!?!?!?!?!?!?



@justanotheryoyo is correct that these features have not been implemented in the offline mode, which is not meant to be the primary feature rich user interface of the product.


Post must be at least 20 characters long. :)
1 Like