Error updating from MMOS to SimuCUBE

I have tried to update from MMOS to SimuCUBE latest firmware version. Now SimuCube shows the error “Drive firmware update error. Turn system off and on again”
Unfortunately I had not read the user guide carefully and did not connect to IONI Pro drive via Granity first.
According to other posts here the error reason could be that automatic IONI firmware update failed. My System (IONI Pro HC, small Mige) is from November 2016 (Simracingbay). I have never updated IONI firmware or even connected via Granity before.
According to the user guide I enabled IONI USB configuration and tried to update IONI firmware manually. Unfortunately the connection is not possible. (Error: Unable to connect. Possibly incompatible COM adapter selected or device is already used by another application.) I double checked that both usb cables are connected to the pc and even updated the SimpleMotion V2 USB adapter in Windows. But still no connection possible (see Screenshot).

Do I have to reflash MMOS again or is there anything else I could do first?

Try this:

Click Update Firmware in SimuCUBE Configuration Tool. When it says “Found SimuCUBE in Firmware Update mode”, do not click next.
In this mode, you could be able to connect via Granity.

Report back if it does not work out for you.

That has worked.
Thank you for your prompt reply.

hello. i have the same error after updating to simucube but in granity i don’t have any communication interface???

You need to have both USB cables connected to the Simucube board. What have you installed so far?

i m connected with the 2 usb

thanks a lot for your help. in simucube i enable ioni configaration usb but i only have tcp ip in the granity software.

the error

enable ioni usb

new error and impossible to update ioni

You are probably missing the FTDI driver for the X4 USB port (the right port) on Simucube, or wrong driver is been installed by Windows.

is it possible to instal it manualy?

You did have a look at the Communication interface device dropdown in Granity and it does not list any COM ports, right?

yes i do and there is not list.

Check Device Manager for any unrecognized USB devices. Install this driver for any FTDI Serial Ports:

Also, if you have SimHub running, it could steal scanning of COM ports. Close all other software other than Granity and Simucube, that might help.

i instal drivers and now i have somes choices in the list.

great! Either the COM ports in that view should work, as long as the Simucube is in the IONI configuration mode. You need to upgrade IONI firware to at least version 1.6.0 (but the latest one is recommended). You do not need to reset motor parameters when you update firmware.

Now it s ok for the ioni firmwire but i have another problem with the motor configuration

Does the motor initialize when you are in Granity? Show the testing tab and the fault limits tab.

Ok, show rest of the settings as well. At least the over current tolerance should be at high or maximum on a Simucube application.