EMI interferance after Simntronix Encoder install - help!

simucube

#1

Hi,
Please could anyone try to help with a problem I have got with my sim racing setup?
I have had a Simucube OSW system up and running for a long time with no issues,but I recently swapped out the standard encoder in my large Mige motor,for the Simtronix version.

I installed the encoder and set up the Granity part of things with help from a friend who had done the same install on his motor.
I went into iRacing,and drove around for a while,and the motor was working as expected,but i noticed that the buttons on my steering wheel were activating without being pressed.
I checked in DiView,and sure enough,I could see the buttons activating with no input from me.
My wheel manufacturer said it was EMI interferance,and it does seem to be this,as the issue stops when i remove the wheel from touching the motor.
I didn’t have any problems when the wheel was not in contact with the motor.

I have run a ground lead from the motor to my 80/20 rig,and already have ferrite sleeves on all the cables involved,and I still have the issue.
I then decided to re-fit the original encoder and cable ,as I didn’t have the issue with those items,but it is still there even with the original equipment.

I didn’t alter the settings in Granity back to what I originally had though,could you look at what I have set,and see if you can see anything that might have caused this to happen?

I don’t know what to do next,my system has gone from working okay,to not being able to use it at all.
I’m not sure why the motor would suddenly start kicking out EMI,even with the original encoder fitted ?

My hardware configuration:
Simucube firmware 0.9.7 -(drive type)
Large Mige/model no. 130ST-M15015 -(motor type/model)
GraniteCore firmware version 1.7.1,Ioni drive version 10701 -(drive firmware version)
-(other details)

Problems arise when:
When sim racing wheel touches adaptor on Mige motor,causes buttons on my USB device to operate when not touched. -(describe how/where it happens)

How it behaves:
The motor does not sound audibly noisy at all ,but the USB device operates without input when touching the motor,and does not have the issue as soon as direct contact with the motor is broken. -(describe system behavior)

I can’t upload my settings.drc,as I am a new user,but here is a link : https://1drv.ms/u/s!AmuCcOHYWO_cg1Y1zXvQ8E4jZiAc

I’ve included my settings.drc and also screenshots of the Granity settings.

I am hoping that it is something in the settings,as the original encoder does the same thing,and everything was fine before .
I could go out and buy another wheelcase,and still have the same issue,if it is the motor that has somehow developed a problem?

I appreciate any help you can give,

Thanks

John.

Note: you can tag the best answer as solution. This helps others to find the solution to the same question.


Simucube - BUG with other usb controler (buttons activation)
#2

Hello,
Short answer is you need to ground the button controller on your steering wheel, this is the classical symptoms if that hasn’t been done.

Below a post I made on iRacing some time ago when this was a concern for many people, it should give you a basic idea how I did it back then.

[quote]Update - External Grounding, eliminating EMI - added 26 Nov 2015

Hello All,
Below a few pictures of my standard external wiring to remove EMI 100%. I use this on Lenze, MiGE, AKM servos, but this will work well for any DD FFB wheels…

I mostly use 16ga cable, except for the pedals, where I use 22ga for practical reasons.

Firstly, I ensure I properly ground the motor. I run a cable from the unpainted face of the servo, to my stainless steel wheel mounting tray…you can see the cable from the bolt on the top right to the one on the Ascher mount, front right-hand side…

Next up, note the two cables underneath my mounting tray…This is of course now connected to the servo ground, as I am using a SS plate…

The one goes from the mounting point above, to the back of my computer case - an easy place is normally just to secure the earthing cable down to one of the PSU screws…
Please again nite, in this case, the screw is of bare metal, nickel-coated brass, and makes firm contact to the crew threads in the case…so no need to scrape paint of the case…

The other cable from underneath the tray, goes to a simple splitter…

Of course, the one end connects to my ‘OSW’ controller box, and that controller box, as is the case of your computer case, is connected back down to your house grounding soy stem via the standard IEC power cord…to easy, isn’t it.

The other end of that connects to underneath my pedal tray, where I have made a couple of earthing straps to link my 3 HE Ultimate pedals together…this was necessary as my pedals are mounted to a 60mm thick piece of pine, and we need to ground them, as well as the electronics…

The cable mentioned above comes from the splitter to the one in the middle…joined to the thinner one…

Connected underneath the pedal tray like this…

And note the thinner cable, which then runs to any ground (Gnd) pin on the controller board on my pedals…

For the wheel controller, I run a simple Gnd cable from one of the ground pins on the button controller board, here I am using a BBI32, as an example, to a bolt on my QR1 quick release. Again, note you need to make contact with bare metal on the QR…I use a simple spring washer underneath the lug, this will cut through the anodizing, but in any even, use a multimeter and test for continuity from your Gnd pin to the servo once the wheel is mounted to the servo…

Please note, if you are using an all metal frame, like 8020, you will require less Gnd wires. But my method works well, is pretty quick and easy and guarantees a working system.

Cheers,
Beano
[/quote]


#3

I was reading your post, and then though maybe Beano can give the best tips. Upon continuing to read after a distraction, exactly such greatness has happened. :love_you_gesture:


#4

Hi guys,thanks for the quick response :slight_smile:

I had seen your post Beano,and had looked into grounding the button box,but it is enclosed,and from opening it up,it looks like I’d have to fully dismantle it.

It’s an SSRG wheel,and speaking to the guy that built it,he has run a ground wire from the bodnar board inside,and connected to the shielding on the USB cable.

There is a metal gland where the cable comes out of the wheelcase,would a ground wire connected to that,and then to my Q1R quick release work?

Here is a link to a review of the wheel I have,sorry it’s a long video,but you can see what I mean,as the reviewer takes it apart.
https://www.youtube.com/watch?v=1-p0ZoJCoq4

I’ve taken the lid off,but didn’t go any further for fear of breaking something.
If I can connect to the metal gland and then to my quick release that would be easy to do.

Thanks

John.


#5

Lols @ Mika :slight_smile: I am almost flying out to Tampere, few more hours, will be arriving Thursday morning and stay at Sokos Hotel Ilves in Down Town!

@John: That will work, just make a secure connection, make sure to connect to some bare metal on your QR!! Check continuity with a multimeter after, between your servo and the button-box ground.

Keep us posted, 100% sure this will resolve the issue for you.

Cheers,
Beano


#6

Thanks a lot,I’ll try and hook up a ground wire from the gland to the QR tomorrow and let you know.

I don’t understand how the grounding works though,as the QR is connected directly to my wheelcase,which is made of metal,isnt this grounded already as its metal to metal directly touching?

Sorry if this is a newb question

John.


#7

Often the cases are anodized, and the QR could be anodized, you need bare metal-metal contact. Once you have that, you should be fine.

If the problem disappears if you remove the wheel from the servo, it tells me there is a ground missing between the button controller and the servo :slight_smile:

Had that question many times, helped the guys to fix it with my solution.


#8

Another option for grounding if the shield on the USB is grounded in your controller and you have a GOOD USB cable would be that it could be grounded at the computer end of the USB cable as well but if it can be done at the wheel that is probably best…


#9

Hi guys,

I have filed away the anodising on my Q1R quick release,and also on the wheelcase where it connects so it is bare metal both sides.
I have also used serrated washers and also a small ground cable between the Q1R and the wheelcase and bolted it back together.

I did a continuity test between my servo and the rig,and got a good connection,then tested between the servo and my wheelcase,and good connection there.
I even tested between the servo and the USB plug that goes into the pc,and to the metal encoder plug that goes to the Simucube.

I turn on Simucube with wheel connected to servo,and my buttons are activating without input again.
I test continuity again,and it is fine from servo to buttoncase,fine to the Q1R.

I disconnect the wheel from the servo,the problem stops.

I switch off the Simucube,the problem stops.

I also disconnected the wheel from the servo,and then ran a ground wire direct from the wheelcase to the servo,and the problem is there - this is without the Q1R being connected at all.

It seems as if the grounding is causing the issue?

I don’t know what else to do,other than spend more money on something like an Ascher wheel controller and hope that my existing SSRG is the cause,but then only to find it isn’t that at all.

What do you think about my SSRG wheel having an issue with the pcb inside?

This issue happened when I altered settings in Granity for the new encoder,is there anything in my settings that could be causing my motor to do something it shouldnt?

Thanks

John.


#10

I don’t have the Simtronix Encoder, but I was having all kinds of heck with EMI and my wheel buttons spontaneously signaling due to EMI on my Large Mige/Simucube/10,000 encoder system. I tried all kinds of grounding (probably incorrectly), and finally settled on a physical solution I described per below in the iRacing forums.

After stringing ground wires all over creation, calling in witch doctors to perform voodoo rituals over my Mige, and offering my wife’s Chi Hua Hua as a blood sacrifice to the electrical spirits which haunt the realm of OSW, I finally resolved intermittent EMI issues with steering wheel buttons by a trip to ACE hardware.

I took my quick release with me and got six nylon (plastic) flanged bearings that slide into and fit over the bolt holes of the QR and hub, and nylon washers for the nut to bolt connection. I crafted a thin wood spacer to replace the metal spacer that was between the shaft/hub adapter and my quick release. Now there is no metal on metal from hub to QR. All EMI issues gone.

I had to downsize to M4 bolts to fit inside the nylon bearings, but with six, they seem plenty strong for pretend driving.

It was simple and cost a few dollars, has saved loads of irritation, and the dog still gets the warmest part of our bed.


#11

Yeah, I suspect you have created a ground loop, and @manashttu’s solution broke the loop at a suitable place. I would start to experiment with actually removing grounding from one place at a time to find a solution.


#12

Thanks for the help manashttu,it was exactly the way to fix my problem.

The screw isolator sleeves and nylon washers to separate the quick release from the motor shaft adaptor stopped all the interferance.

Thanks again guys

John.


#13

Diablo . . . very pleased that helped with the EMI. When I’m ready for a break from actual driving and crave some gadget tinkering, I may follow up on Mika’s thoughts regarding a ground loop. I’ll fiddle with my wiring to see if that is a core problem, and if I find a breakthrough, will share it here. In the meantime, if some plastic and wood let us enjoy the rig . . so be it.

A what a great wheel system it is. This DD wheel has improved my consistency and enjoyment in pretend driving tremendously.


#14

Yea you solved a Ground Loop condition (used to do this with R/C Cars all the time to gain Radio Range… I think most of the So Called EMI Issues are due to ground loops more than actual EMI… @DiabloSandwich if you can isolate the button Plate as @manashttu has it will probably solve your issue.


#15

Hello Philip,very nice presentation!One question please.Where do you use spring on the wheel side?