E stop pressed, waiting for the drive to get ready

My SC2 pro is new, I have just mounted it and it’s the first time I use it. I’m stuck at this, and it doesn’t work, I’m a little bit disappointed about the quality, let’s see how is the support now.

Do you have the e-stop button connected and does it mechanically work ok?

My E-stop is connected, I don’t know if it works, but mechanically yes, I can press it, there is a “clunk” if I full press it, so I guess mechanically it works.
If I dont connect it, it’s the same.

If you wrote a support ticket, you will get sorted tomorrow or soon after. Its the summer holiday season and myself I will be out from Internet almost completely starting tomorrow.

I have written a ticket. No luck for me I guess.

we do not work in official support system on weekends.

Except me, when I’m not on my annual holiday :slight_smile:

Thank you very much, I hope we can find a solution, I really want to use my SC2 pro :wink:

I update myself, I have ‘turned’ the estop, it was probably locked pressed, I didn’t know I can turn it to unlock, and I have turned it, I had a bip, and now this :

Maybe it works, I will report later, sorry if was only that I didn’t know it was locked pressed


Sure It works now, Happy Driving!

my wheel is never detected, and it’s not centered

What wheel is that?
And, didi you tried to calibrate the wheel in the first tab?

Yes, the button is a latching button. You need to twist it to get it to pop back up

its ok now it works, I have turrned the wheel “'on”.
About the centered, is there an auto option to find the center automatically ?
I use asher box gt 24M wireless

The base per se does not have a center position. The center position is what you set it to in TD. Just put the wheel straight and hit “Reset Center”.

thank you, and is it good to put unliimited Torque bandwidth limit, or I have to use 2200H or higher ?

Use the “enable high torque” gimmick at the top right! Behind it there is the forbidden land of true simracing power!

Did you do even the slightest readup before you bought the wheel?

thank you, all is very well configured now for me.

So what is the verdict on support now?

Very good, even if I have found the solution alone. I will see if my SC2 pro is really broken, now it works perfectly.