Does anyone here own a Cube Controls FPro wheel?

Just wondering if there’ve been any downsides to the fpro using bluetooth instead of Simucube wireless.

I assume the games that support simucube to begin with all support multiple input sources for button boxes, etc…

I bought the FPro too. I first tried connecting it via bluetooth, but the wheel kept dropping out.

So then I tried connecting via USB, and again the wheel kept dropping out.

I return the wheel to Cube Controls, and they just returned it to me saying there’s nothing at all wrong with the wheel. So not sure if it’s my machine that’s the issue, or the Simucube interfering with the Cube Controls signal, but I’ve not been able to get it to work just yet.

So I went back to my Ascher wheel (for the time being) which is faultless.

I have the fpro (from the first batch for customers) and always use it through Bluetooth. I have no problems with disconnects or sim button assignment.
Noted, the wheel is about 40cm away from the external bluetooth antenna of the pc.

The usb cable i use only to charge the wheel.

1 Like

That’s interesting. I haven’t tried it again since I got it returned to me.

I’m going to give it a try again on bluetooth this evening and see if I’m still getting the disconnects.

Do you experience any lag at all with the button presses? I was noticing a good second lag between button presses, and sometimes the game not even registering the button press at all.

No lag at all.

Did you try on another pc? Maybe try to connect to another pc, just to see if there is the same issue.

how often do you need to charge on a bluetooth connection?

The leds are the battery drainers, with those on I have to charge after about 3-4 hours.
With the leds off, i can use the wheel for days.

1 Like

Same experience here. LEDs kill the battery.

it’s very little :-(. I regret that we don’t have QR like simagic or Moza

I own this wheel.It is pretty great. buttons are very clicky and have nice feedback. rotaries are great. I can get a couple days of playing with the buttons full brightness, and i can play forever with them off.

There is ZERO input lag on bluetooth. Boosted media also confirmed that on his review. I have a fairly nice ROG gaming motherboard and It connects flawleslly. Unless your system is old, has a weak Bluetooth signal or needs a BIOS update, I dont see why you would have an issue with bluetooth.

I looked into ascher wheels and while they are great, they just look meh. They are like really well built mario kart controllers. The F-Pro feels close to what I drive when I track real cars. For the price, I think its one of the best options out there. I spoke with their team a couple of times and they give you 2 weeks to try it out. I highly recommend it.


I’m on a 12900k, Z690 with a 3080ti.
So whilst it’s not a top of the range PC, it’s not right at the bottom either. There shouldn’t be any issues with my bluetooth connection.

As for Cube Controls buttons, yes, the wheel is very very nice, but I still think the Ascher buttons are better. A lot better. They’re easier to press and have a nicer, more positive, click.

Mechanically wise, I do feel the Ascher is the better wheel, by a long margin.
Looks wise, there is no match, the Cube Controls looks the best by far.

If I had to choose the Ultimate wheel it would be the F-Pro wheel with the Ascher Buttons. Gear levers I very slightly prefer the Cube Controls.
I would also prefer with the LED lights, but then I race in VR.

1 Like

That’s a top of the range spec in anyone’s books. Anyway, that doesn’t mean the onboard BT is working as it should. These things are often a hit and miss in my experience. If I use USB, I always ensure to connect high-bandwidth devices to the native USB ports, not 3rd party ones such as Asmedia.

Easy to test your F-Pro though by disabling your BT in the bios and grabbing a small quality USB BT dongle online. This is what I normally do, I hardly ever use these combined wireless /BT embedded solutions offered on motherboards.

I only use high-end Tier 1 Boards, even then, wireless and BT often pretty crap. Just my experience, of course, other’s mileage might vary…

ASMedia USB controllers is what every MB maker use for USB 3.0. What is “native” here?

In my experience, boards come with a mixture of USB 3 ports that are split into sections and controlled by the various chip vendors.

Sometimes you can do some detective work and if you’re lucky, find block diagrams or pictures that will show which type of controller runs each port.

Here’s an example for my ancient X99 board:
X99A Krait Rear USB Controllers


Spot on, cheers Paul :wink: Yes, I refer to those ‘native’ Intel ports. Andrew, I’m so allergic to Asmedia, that I have purchased a high-bandwidth Startech quad-controller PCIe card, as well as. Caldigit TB4 dock, to connect my high-bandwidth stuff too.

If you check back, we had lots of issues with HMD /VR and DD wheels with Asmedia.


@EsxPaul This is very interesting how can I find this information for my motherboard? Aorus X570 ULTRA.

Phillip, have you tried replacing ASMedia chip driver with the one from Microsoft?
You can do it in device manager by unistalling controller in there and rebooting, Windows should pick up the one from MS on reboot.
It has been known issue, MS even documented it in WMR troubleshooting. .

I can’t find anything specific but the specifications list the LAN port as being made by Intel. With that information you can be relatively sure that the two USB ports adjoining it (1x type A & 1x type C) will also be Intel.

There may be others but that will be more difficult to confirm. Sometimes you can find clues by delving into the Windows device manager tree and seeing which drivers control the various ports.

This is detailed instruction from

And this is how it should look like if things are installed correctly.

I am on X99 Asus RAMPAGE V EXTREME and Z390 ROG MAXIMUS XI EXTREME, never had any issues, spare G2 installation when I had to follow this procedure or USB was marked as incompatible.


Thanks a lot
I will try to search in Windows