Display not sleeping due to HID game controller

I have found that the HID-compliant game controller device that seems associated with SC2/TD keeps my Windows 10 from putting display to sleep when idle. If I disable the device in Device Manager, the problem goes away, but SC2 doesn’t show up in iRacing unless re-enabled.

Anyone else seen this? Any workaround? It even keeps display from sleeping on lock screen.

I have RTX 2080S with latest driver, but doubt that is relevant. This has been happening since I got my SC2 pretty sure. I’m still running 2020.7 TD.

I have investigated this. It also happened with another game controller I have and I was not able to isolate it to Simucube 2. It must be something to do with the Windows updates over the last 3 months.

Lots of information (with no solution) in this thread:


It looks to have been an issue in an early build of Windows 10, but was then fixed. It was OK in build 1909, but has been broken again in build 2004. Affects many game controllers and other devices.

and here.



It seems may be connected to GeForce Experience in-game overlay. If I disable that, display seems to sleep even with game controller enabled. Seems like interaction between the two. I only occasionally use the overlay. Maybe I’ll just disable that when not using it.

I also tried that workaround, it did not solve the issue for me.

It might be my Heusinkveld Sprint game controller device. Now I see the SC2 disappears when powered off.

I’ll keep trying things. Can’t believe MS can’t fix/keep this fixed.

With SC2 off, and In-game overlay disabled, display sleeps with pedals attached. But if SC2 on, it won’t. I wonder why the SC2 keeps it from sleeping, but pedals do not.

Pedals, in-game overlay enabled, but SC2 off does not sleep.

Confusing. I am running 2004. I have option updating to 20H2. Wonder if that would help, but who knows what else breaks.

Thanks for your help!

I get this as well from my Thrustmaster Sparco TSS Handbrakes, and used to get it from my TS-XW. I power off my Simucube 2 so perhaps that would be also contributing, but my solution was just to unplug the USB cable that goes to the hub that has all my racing stuff on it when I’m not using it. Super irritating, but not a huge deal in the grand scheme of things for me.

A lot of HID game devices seem to cause this problem, I think it’s honestly a Windows 10 issue that they really need to fix.

Agree this seems to be more of a Windows and/or GeForce Experience issue.

Microsoft has now put up an update:


“Updates to improve security when using external devices, such as game controllers, printers, and web cameras.”

I haven’t tested this yet.

1 Like

The issue still persists in Windows 11 :frowning:

Windows 11 is Windows 10 with new UI :rofl:

1 Like

I have also made extensive tests. The last version where screen sleep works with connected any gaming controller is windows 10 1909. After it - no, and MS does not care …



  • This update addresses an issue that affects some game controllers. When the game controller is connected to the computer, the computer might not go to Sleep mode.

I still dont believe it :slight_smile:

I think I got this issue with Razer Orbweaver Chroma, monitors refused to turn off with it connected, took a bit of plugging/unplugging to narrow this specific controller down, started happening after one of the big Win11 “feature” updates.
Windows update from 2 weeks ago fixed it though.
Not sure if the same was happening with SC2 running, I usually turn it off when away from PC.