Disappointing day one

Thanks to everyone that helped out a new user before.
I have tried other USB cables, by-passing the USB Hub and connecting USB to a different computer - my laptop, but I can’t get new, out of the box Simucube 2 pro to work.
I bought an Ascher Wireless button plate to connect to it, I can initiate the pairing on the wheel - there is a green LED that flashes and I can see the wheel in Bluetooth devices on my phone.
I have tried the latest version of True Drive, tried an older version from Dec. last year.
There is no view of the Simucube in the hardware tab of the software. There is a green LED lit on the PSU. I have checked cabling and connections but really need any help as I have not read any other advice on this forum to try next.
Going to bed pretty unhappy with my purchase… At least I could do laps with my G25 but it took many hours to install the Simucube nicely into my 40160 rig. I’d like to think there was no going back but to add insult to injury, I imported my simucube from the UK and I’m in NZ, so shipping couldn’t be any worse. Trying to save a few cents is going to cost alot of dollars in freight I suspect. :cry: :cry: :cry:

Have you connected/checked the emergency stop button connection?

But I’m not sure what is the problem. You have connected all the cables, but truedrive does not find it? the “i” tab shows nothing? (when I turn my sc on, the text on that page turns white instead of grey.)

In device manager, com and lpt ports, how many devices do you see connected? If you have Simhub, go to Arduino, my hardware, multiple Arduino settings (or single), scan for new devices and you will see the result at the right side: one of them should be the Simucube 2, and you also should see the com port it’s using.
In the classic view of control panel you aswell should see the Simucube 2, under the hardware tab, show hardware and printer.

Thank you for your suggestion. I have an awful confession to make…

And thank you, my horrible confession is I raised a support call - and support responded promptly… Have you turned it on at the power switch on the back of the Simucube?

Yes, I’m looking for the nearest hiding place. Thanks again.


Hopefully the following days will overcome the disappointment.


I ALWAYS mentioned that in all the 2’152 groups I’m in, the 412 expert councils I’m a member, in the 45 videos I did on YouTube, that there is something wrong with this tiny button at the back of the Simucube 2 models. And my conclusion was: it’s the “best worst not wanted to be hidden hidden” button ever. I was told that @Mika had at the time of the design meetings a very clear meaning about the location of the button: he, I quote said “this button won’t move a yotta, or I move a million of miles”.
So clearly not your mistake, nor could you know that a Simucube 2, although having a PSU, must be switched on. To support your case I’m more than willing to provide you a hide out, here it is :hole:

In their defense the button is labelled “power” right by where all the cables are plugged in. Motor board is also right on the other side of the back plate.

This is actually amazingly common these days, especially amongst the youngsters

10 or 15 years ago it wouldn’t have entered my head to ask somebody if they’ve turned it on. Now it’s one of the first things I ask if somebody can’t get a device to work.

To be fair though you never really turn anything on or off anymore, so it’s unsurprising that people no longer think about turning something on to get it to work.

I still do, especially because my electricity bill is reaching out to the frontiers of the atmosphere…

Make sure that you are using the latest version of the Simucube software. You can download it from the official site.
Check if all cables are properly connected. Make sure that the USB cable is connected directly to the computer and not through a USB hub.
Try restarting your computer and connecting the Simucube 2 Pro to a different USB port.
Make sure that Bluetooth is enabled on your computer and that the Simucube 2 Pro is in pairing standby mode.

It actually might work better through powered USB hub especially if you have other peripherals, and Simucube wireless wheels do not need BT on PC, at all.

2021.7 till I die :joy:


:joy: :rofl: :joy: .

Hello guys… Can I please ask something but to not make anyone mad?

did this guy, topic starter, just make a story how his simucube2pro not working and he is dissapointed… and he just didnt press button to turn on the base?

wait a second…


I swear guys you made this day, week and month for me.

thanks :heart:

1 Like

Haha, yes, these things happen :slight_smile:

1 Like

People these days simply don’t understand the need to turn something on or off, or even the need to activate something.

I’ll guarantee to you that in 80% of cases where I ask somebody to turn off a laptop they’ll just close it, and not actually shut it down

In recent times a simple power outage will cause the tech support lines to be flooded with people that need to be not only told to turn the machine back on, but also to be told exactly how to do it,

Following, it’s kind of a plague.
Most of the time the solution most obvious, recommended and simplest one is also the one people have to be pointed to. I have some basic stuff, and I’m sure others have more of it, and of more importance. Maybe we can do a little collection, a “first aid kit”:

Windows is in a loop, turn off the PC, remove power cable, maybe get rid of power stored on top, wait a few minutes… helps in most cases.

You can’t connect Bluetooth, decouple the device, check out if is connected to other devices like smartphone and try again. Not solved, uninstall/delete it, remove network cable, shut off, wait a little bit, turn on and do a new search. If it shows up, pair the device.

USB hub doesn’t work no more, or device running with hub doesn’t work no more: open device manager, check “show all devices”, search for device that makes problems, unplug what is plugged in, turn it off, uninstall/delete it, restart PC.

Simucube 2, after starting the PC, power on, run TD, choose your settings, close TD. If you have “high torque always on” it will do a perfect job.

Problem with vjoy driver, uninstall it, restart PC and try to enter"extended start options" by hitting F8. No luck, go to Windows settings, choose restore. Restart PC, choose start options, hit the number ( think is 7) “deactivate force driver signature”. In Windows, install vjoy as administrator. Should do the job.

Graphic card problem: check power supply and connection to PC. Download latest driver and firmware. Check device manager, look for the card, uninstall driver and software. If needed, restart PC. Do always clean installations, rather than installing over the existing solution. Also check settings in BIOS, PCIE, preferred graphic card, resizable BAR settings

1 Like