Crashing and Failure to be detected

iracing
firmware
simucube

#1

I brought my DD wheel from you back in 2017 and I never had any issues with it. But the other day Windows did an update which affected the SimuCUBE box. It no longer registered to have a motor and also the SimuCUBE software keeps crashing after I turn the box on.

I have done:

1.)Updated the Window Drivers and Windows itself
2.)Updated my Bios
3.)Changed USB Ports
4.)Tried to change to different versions of the software
5.Changed the Mini B Cables (Thinking that might be the issue)
6.)Did many restarts and reboots of both the computer and SimuCUBE box
7.)Removed the SimuCUBE from my Control panel and uninstalled the drivers and had Windows reinstall them.
8.)I tried using it on my backup computer and I keep getting the same error and result.

Before this problem happen, my simcube box was doing some wagging and data loss and receive which affected the way the wheel handle itself when in game aswell as in software. It seemed like there was a data loss and it went blank for a few moments and can came back.

In theses link by gyazo. It is showing that the SimuCUBE is not being shown in my Devices manager and the main error code which I keep getting

https://gyazo.com/b42c24bc117f258d1d383869ceb92eae

I am available to do a TeamViewer go through or a phone call or whatever I have to do to fix this issue. It worked fine before that windows update but now it seems like the simuCUBE just isn’t putting the correct data or code anymore to make it work.

I do look forward to hearing back from you and I hope we can get this issue fix and received before iRacing.com week 13 begins.


#2

It seems to me you need to start at step 1 and verify which FW version you have on the Simucube and which version GUI you are using for it.

The FW and GUI needs to match up. Looks like yours is trying to flash something, or it is in dfu mode perhaps, not sure.

Show what you have in Device Manager. Most likely PEBKAC error somewhere :wink:


#3

This morning I took the top of the SimuCUBE off to look at the motherboard and I notice that the LED on the IONI chip was first green on startup but after that, it turned orange. It was doing LSSS and the forums said that a SimpleMotion communication error. I can’t find anything on the forums and or on Google itself to see if I can find why it’s doing that an how to fix it.

I am kinda confused cause that SimpleMotion are a communication link and Argon drives and I have a SimuCUBE. But I don’t know

I also updated my Granity to 1.14.2 and on the app where it says “Connection to drive” it’s having a drop down which is "simplemotion USB (FT230X Basic UART) and once you click on "connect to drive) it’s not finding and anything on the SimpleMotion Bus. I also tried to update the FTDI / Virtual COM port but it also failed when trying to fix the wheel both Granity and SimuCUBE Software.

Also, want to note that the motherboard also has a LED on and that’s light is a green which is a solid color which is green on LED 3.


#4

The firmware seemed to have hanged up for unknown reason. Reflashing helped.