Computer won't boot when i start Simucube first

simucube

#1

Like the topic name says.

When i start up my Simucube and let the phasing come to an end and then start up my computer, the computer won’t boot.
If i do it the other way around so startup computer first and let it boot then it starts up just fine.

Any idea’s what could cause this?

And could it be related to my problems with ffb going numb and never coming back until i restart rFactor 2?

My Setup:

Small mige, 2500ppr encoder run by a Simucube with ioni pro hc and 320w psu
Firmware 0.8.4
Computer I7 4770 Windows 10 pro 64bit psu in computer 700w silver grade.


#2

You are not the first to report this.

Your issues are not related to each other.

The non booting issue is most likely something to do with the usb interface descriptor of the SimuCUBE device. I encourage everyone to try to find it…


#3

Also, motherboard model would be important to know. Also the point of freeze - is it in the bios screen or the windows 10 loading screen?

By googling, it appears that even some logitech mice and usb hubs can cause this to happen. So it might not be a SimuCUBE specific issue.


#4

Are legacy usb devices enabled in bios or not?


#5

Motherboard is a gygabite model nr i will report later.

The point of freeze is even before the bios screen. The screen only shows a blinking cursor (dos screen) top left. As soon as i turn simucube off then bios screen appears and next windows starts without problems.

I also found when i close windows and shut pc down, and afterwards i turn of simucube. Then sometimes pc starts to reboot all by himself as if it got a signal from the simucube.

I use a cheap logitech mouse and powerd usb hub.
Simucube not connected by hub but directly in back of pc.
Hub and mouse i even had long before simucube and they never caused problems.


#6

Legacy usb disabeled


#7

Motherboard Gigabyte H81M-HD3 (including HDMI)
And to be complete my gpu is msi gtx 1070 gaming
8gb 1600 ddr3 memory

Connected devises with usb
Simucube
Heusinkveld pro pedals
Oculus rift
Rift sensor
Logitech headset
Usb3 hub with trustmaster shifter, mouse, keyboard


#8

I also have a Gigabyte mobo. In addition I have rift/ sensors, DD wheel, Fanatec usb adapter, pedals, shifters, 2 button boxes.

I have not experienced this issue. In fact I just tested it several times. No boot problems with Having the Simucube on.

Hope this helps


#9

My guess would be buggy motherboard bios that causes this.

One thing you could try, is to shut down SimuCUBE. Press E-stop. Start SimuCUBE, Do Not release the e-stop, then reboot computer.

In this state, SimuCUBE is not yet sending any USB HID reports to PC, so it would appear “quiet” to Bios.

Report back what you find by doing this.


#10

I will test it this way tomorrow Mika and report.
I know for sure that it hasn’t been this way always and in my memory it started after the autum update from windows 10 but you will know way better than me if that also could be a cause.

As said i will report tomorrow


#11

Like you requested @Mika. I started simucube let servo run phasing then press e-stop and try to boot pc.

Pc won’t boot


#12

Do it as I said. Do not let servo to phase.


#13

Sorry ill tried again. So i pressed e stop and then start simucube. After that i boot pc.
Pc starts but takes very long…longer than normal


#14

The device is bootable flag is off in the usb interface descriptor, so shouldn’t affect booting in any way.

Still thinking what could cause this.


#15

no hurry i can live with this :wink:


#16

Mika, I just want to chime in that I have a very similar problem.

Regardless of estop status, my computer hangs at the motherboard splash screen if the Simucube is powered.

If I switch the Simucube off, the PC will continue booting. I don’t even have to restart to let it progress - as soon as the lights on the Simucube go out, the boot process unsticks and continues normally.

I’m running the most recent beta firmware.


#17

I have tested every PC I own at home, and two pc:s at the office. None of them exhibit this behavior.

Could someone please test if it continues to happen with the following procedure.

  1. Start everything normally
  2. Click Update Firmware button
  3. Run the wizard so that SimuCUBE goes into Firmware Upgrade Mode
  4. DO NOT run the actual firmware update. Close the tool instead
  5. Verify that SimuCUBE in Firmware Upgrade Mode is visible in the devices, instead of just SimuCUBE

Now, do not turn off SimuCUBE. You can just power down / restart computer to see if the hang happens. Please report back your findings!

To recover the SimuCUBE to normal mode, turn it off and on again.

This will help me pinpointing whether it is something in the FFB / Game Controller device descriptor (which is very, very long set of USB device descriptors…) or some code-based thing in the USB stack.

Thanks!


#18

I am still not back at simucube firmware Mika. But i can tell that the same behaviour is present with mmos.
I could set mmos in dfu mode and restart computer i don’t know if that would help you.

At the moment i would like to stay at mmos because of lots of practise/testing and don’t have time to experiment to much with my wheel.


#19

The DFU mode (factory bootloader) is a completely different beast to the custom bootloader we have with SimuCUBE firmware. In fact, the custom bootloader uses 90% the same code than the normal SimuCUBE firmware.


#20

Ah ok. Then for this moment i can’t be of help for you.