Cant Update Firmware: Software Crashes / Cant find Base in Update Mode

Hey guys,

I just got my SC2 Pro and was really excited till I want to set everything up. I can connect the Base via varios USB Ports (2.0 / 3.0) but need to extend the USB about 2m (never had any issue with my DD1).

Once I plugged everything up and started the True Drive Software the first time, the Software said I needed to Update the Firmware, after clicking next I got an Error after 30s whichs says the Base is not in Upgrade Mode.

After a look into the device Manger I cant see the Base in any way (Its under USB Input Devices but thats it, there are like 6 and I dont know which is which).
After a restart the True Drive Software just gets stuck (message that says doestn work anymore with a grayish background version of TrueDrive). Once I unplug the base, it instantly “works” again.

I tested this on my girlfriends computer and a latop and all 3 get me about to the same result…

what can I do? Is the base defect?

Have you released the emergency stop button?

ETA: From the manual:

First start
On first startup, it is likely that the True drive software will show a firmware update prompt.
Update the firmware using the wizard. True Drive will close upon successful finish of update, and
relaunching will give user normal access to software.
Note: Take care that the torque off button (e-stop) is not pressed in on first power up when going
to firmware update

I suspect this indeed the case. It is also mentioned on the very first page of the firmware update window.

Twist the button slightly and it will pop up.

The twist was I did not connect the emergency button, because I dont need it. The moment I connected it, it kinda worked.
WTF…this needs to be put into the manual…

it is already in the manual