Can't install firmware on Ioni

My simucube 1 / ioni osw won’t update the firmware. It erased the firmware at the start of the update but keeps stopping at different stages of the install. Sometime straight away mist times it gets part way through before error messages occur saying firmware not installed and error messages regarding time out and disconnect etc.

I’ve tried on several PCs and get the same issue.

Worked Ok a month or so ago.

Any ideas?

For efficient support requests, please consider using the template below. Fill-in the (blanks) and provide additional info when necessary. Thank you! Best regards, Granite Devices team.

I have a question regarding (product) regarding (issue).

My hardware configuration:
-(drive type)
-(motor type/model)
-(drive firmware version)
-(other details)

Problems arise when:
-(describe how/where it happens)

How it behaves:
-(describe system behavior)

How I would expect it to behave:

I have attached following files:
-(consider adding saved Granity configuration file .drc)

I also would like to share that (additional info).

Note: you can tag the best answer as solution. This helps others to find the solution to the same question.


Is it really a Simucube system? Which firmware versions are/were you running?

Yes it’s a simucube board with ioni what a bizarre question.

It’s got no firmware in ioni as it erased it when doing the update, now failed to do the update so now the simucube config tool won’t connect to the ioni drive.

Which Simucube firmware version does it have?

Not sure it auto updated that when starting up simucube config program

the version data is on the last tab in the Simucube software.

I’ll take a look later. Does that really make a difference to installing ioni firmware via Granity?

no, Simucube firmware will automatically install the correct version. There is no need nor any benefit to manually update IONI firmware via Granity.

Heres the firmware versions showing in simucube.

Operating mode says couldn’t connect to ioni reconnecting.

There has been a previous case where the IONI has failed in a similar way, and needed to be replaced.

To rule out the Simucube affecting the update somehow, please power off the Simucube and put it into DFU mode by using the dip switches, then try to update the IONI again.

Very valid question. :slight_smile:

Ioni was used on 3 different boards and the Simucube software will only work on the Simucube board.

Many people over the years have tried to install Simucube software on Ionix1 board with Ioni.

So this is a system that was up and running 2 days ago. Now via Granity its erased the firmware that was working and is failing to install it again.

I’m rapidly running out of patience with half hearted responses and Wiki instructions which don’t refer to things properly. Where is the instructions showing how to set the dip switches. This is a new Simucube board (after the last blew its Mosfets) that I installed perfectly easily 2 months ago and had up and running now I’m doing it all over again and I can’t seem to get it working or more importantly find the right information to at least attempt to get it working.

Using DFUsedemo it doesn’t give me any devices to connect to in DFU mode.


There are exactly two dip switches on the Simucube board, on one single block. The look like this:

Most likely, as your Simucube board is quite new, the DIP switches are on the edge of the PCB near the green connection block that the fan connects to.

The other one is not connected to anything, and the other is toggling the DFU mode, so you can always toggle both of the switches. IONI firmware can’t be installed with DfuSeDemo, but putting the Simucube into DFU mode you can exclude the Simucube from trying to do anything that might cause the IONI firmware update with Granity to fail.

Also, having E-stop pressed might be helpful. Also trying with another USB cable for the X4 USB port might help.

Where are you at in the world?

If you are in the USA I may be able to remote in and help you get squared away.

OK, so that worked thanks, I now have the firmware installed on the ioni. However, I now have the continual error message that drive needs to be restarted, you can restart manually from the connect tab. So I have clicked restart drive several times and it searches the address and then I can connect, but then the error message about restarting the drive comes back.

I have tried powering on and off, e stop open/closed etc. Simucube says waiting for drive to get ready.

Usually that is due to a bad parameter on the drive. Can you show the settings in Granity, and also the testing tab?

At least Motor Type = NONE
is wrong, should be 3-phase AC