Can’t seem to upload .Drc file


#1

-No Drc & encoder appears in Configuration Tool in SimCube FW although I have game profile stored.
-Tried uploading Drc after connected to Granity. Messages appears in Granity - This info updated only after Connected-, although I have already connected to Granity.
-Tried in Dfu Switch Mode still get the same message
Odd behaviour


#2

The Configuration Tool lists all the DRC files in the program installation directory. We are currently not shipping any DRC files, as people most likely would try them out and misconfigure their systems.

You will need to enable the IONI USB Configuration Mode first before connecting to IONI Drive in Granity:
image

The error message in Granity is most likely the error message that means that you have NOT connected to IONI drive. You must press the Connect To Drive -button on the Connect -tab.
image


#3

Hi Mika, thank you,

That’s the strange thing about it. Because I can confirm I am connected to Granity as described- when I receive the message. After having enabled ioni communication in Simcube FW.

I am able to upload the latest ioni firmware without any issue whilst connected. But not the drc from Tomo’s webite where I purchased 2.1m encloder for my PSU which 480/720w. I have latest Granity FW Version 1.13.

Furthermore, The Configuration Tool does not list the DRC files in the program installation directory for me although I have games profile stored.

I have tried DFU Switch Mode without success and showing the same message.

I have attached some images if it helpful.


#4

Granity does that as it will re-read those fields from the drive on next connection.

You show the drc file on the desktop, not in the same folder where the Configuration Tool is.


#5

Hi

Okay if the fields are ok as it is what I think you are saying, does it means that I have successfully uploaded drc file without realizing?

shouldnt I have to confirm the uploaded drc. file in Granity as a final step?

I have tried uploading the drc. file from configuration tool after extracting the drc file into the Simcube folder. Is there a separate Config tool folder?

The drc file on desktop you see, is a copy of a drc I have, after downloading the file from website.

I will double check when I get back, thanks


#6

In Granity, one would

  1. connect to drive
  2. Click load settings from file
  3. Save settings to drive non-volatile memory.

At that point, Granity will ask if you want to apply settings or not. You will also want to press Restart Drive after that.

The SimuCUBE Configuration tool does these things if it just can find a drc file you want to use. I will add a file selection dialog sometime soon.


#7

Hi Mika,

Thank you! I will check this later tonight.


#8

Hi Mika,

Solved, thanks again for your help!!!:smiley:


#9

hello i heve the same problem
in simucube configurationtool i dont see the steer turning when i do
help please help


#10

is the wheel new ? give more info about your hardware and what software version you use. Does it show any faults in the tool ?


#11

hello Loukas,
indeed new two months old.i have been able to enjoy it until last week.he came in power stage off .overcurent fault
id 442001 I have checked the cables and there was a black wire of the power cable not fully tightened. I have also downloaded the firmware maybe something went wrong with this. there are no more error messages.Aantekening%202019-04-13%20124908 Knipsel


#12

SimuCUBE based OSW kit Biss-C – with CM110 case (MiGE 130ST-M15015 Biss-C - 4,2 mil cpr - Mean Well 480W/720W peak (Noiseless) 30Nm - Ioni Pro HC (25A) - Yes - Black MiGE Fully shielded cables with CNC machined connector


#13

3 5


#14

You should change Overcurrent Tolerance FOC to Maximum.

The Firmware Revision ID missing is a known issue in that IONI 1.7.9 file, and will not affect any fault conditions.


#15

I did but nothing has changed.
in the configuration tool I see the steering wheel not moving when I literally turn the steering wheel so there is no contact. everything starts up well but I cannot configure it or use it in a simmaximum


#16

ah, ok. Does the Position Feedback value change in Granity as you turn the wheel? Its on the Testing tab.


#17

Your Feedback Device setting is a Quadrature Encoder setting - if you have a Biss-C encoder, it should be Serial encoder with 22 bits… also you Maximum Current values (MMC and MCC) seem to be strange. Did you reset setting as you uploaded firmware?


#18

you can find your drc settings here https://www.dropbox.com/s/n51e57ov1ti651a/SimRacingBay%20-%20Simucube%20DD%20System%20-%20Manual.pdf

or if you want a direct link here https://www.dropbox.com/s/kqpgzp1g9yivjyd/Large%20MiGE%20Biss-C%204.2milcpr.drc?dl=0

load this drc and most likely you ll be good as new. If you don’t know how , let us know.


#19

really thanks for the responses.
how high should my mcc and mmc be.
I did indeed have the wrong drc file, luckily I moved again in my steer. You could see if everything is now properly arranged.?

Knipsel%203 Knipsel%204
and thanks again man. he does it again.
thanks


#20

there is no norm for mmc and mcc , i have it differently , if you get it from another vendor it will also be set differently. If the wheel works ok for you just leave it there.

to give you an example , i ve seen augury kits have 18 mcc and 23 mmc

they also use unlimited mpp if i remember correctly.