Can anyone spot my EMI issues?

Hi guys,

I have my Simucube Large MiGefor about two years now. Since the last few months however I’ve been experiencing some issues.

Earlier this year I snapped my wheel side USB cable in two while fiddeling with some settings, the wheel went beserk and before I could press the emergency stop the cable was already dead.

I ordered a new bare wire to DIN cable from SRM and after installing I started getting issues with my wheel. Buttons would be activated and random up and downshifts would happen.

Now I know nothing about electronics so the first thing I did was contact Simon from SRM. We’ve been having back and forward chats, he has sent me a brand new conversion under warranty but the problem remained.

Until yesterday I was certain the issue came from the pin connectors inside my Fanatec wheel, heck if the issue didn’t cone back up again I was sure I had fixed it with locking the wheel with the bolt.

So yesterday I started googling again. Well what do you know, dozens of threads with people having the exact same issue, all reffering to EMI.

As I said I know nothing about electronics but if I understand it correctly, an OSW causes a lot of EMI and you need to create some kind of loop to send it back into the ground.

I should add that apart from installing a new coiled USB cable in my Fanatec QR conversion, I also took the time to do some cable management on my rig and stuck a thick rubber mat underneath it to keep my new neighbours happy.

So this is the situation:
Rig
The Rig is an 8020, which I read is good for the EMI loop, but it’s powder coated so I don’t know if it makes any difference. To keep kind of clean i run most of my cables through the grooves.
The motor is a Simucube OSW 30nm with shielded cables.
Attached to it is Simracingmachines Fanatec base side conversion kit. It is grounded internally in the PCB.
On top of that is my Fanatec Formula Carbon. Since the base side QR is grounded and they’re connected bare metal on bare metal I assume there’s no need for a grounding cable here?
My pedals are Heusinkveld Pro’s (which are not grounded and don’t have any issues)

What I think after reading up is that the rig itself has nothing to ground on because of the mat and my controller box sitting on top of a pastic box.

Anyway, i hope this is enough information for Beano :stuck_out_tongue_winking_eye:

Looking forward to your possible solutions!

1 Like

I have just the same problem with my srm and fanatec carbon wheel connected to my mige. Hope someone has a answer for this

1 Like

I had the same problem - maybe even worse - with my OSW and SRM conversion with Fanatec wheels (formula carbon like yours and BMW). I then got a Simucube2 Sport with Ascher plate wheel and SRC GT1, my rig is the same as before (Simlab P1X) and nothing else has changed expect the motor and wheels I am using, so yes, I always suspected the issue was due to some EMI coming from either the SRM conversion kit or the OSW itself (it was a small MiGe).

1 Like

Guys: I guess you did some soldering works.
Did you care for a proper re-shielding of the soldered parts of the cable?
USB cables can become quite a bit sensitive if the shielding (that “foil” reminding of thicker aluminium foil just beneath the plastic sheath) is not properly done, e. g. has gaps.

Use heat shrink tube of different sizes, use that tubes for every single core you soldered, providing a perfect electrical insulation. Don’t use electrical tape - sharp edges of the soldered parts will penetrate this sooner or later. Better use two pieces (one smaller, one larger) of heat shrink tube for each soldering joint.
After that is done, check all cables for short-circuits, then take some common aluminium foil, wrap it tightly around the soldered and shrink-insulated cores AND the untouched shieldings on both previously cut ends of the cable. Make sure there’s no gaps, there’s a wide overlapping transition of the factory shielding with your aluminium foil shielding.
Then put on some larger piece of heat shrink tube, covering everything. Shrink, repeat.

This should solve the problem - if the culprit is degraded shielding.

And of course: Don’t forget to put the cut pieces of heat shrink tube on BEFORE you start soldering. :wink:

Hi Joern,

No soldering involved whatsoever.
All parts added like prescribed.

Hey guys,

Small update:

In my search for a solution and going through several pieces of documentation, I came across a few possible solutions. So in my quest to find a definitive fix, I’m going to go through this step by step to exclude any possible causes.

I spotted something in SRM’s install guide earlier, in the guide there’s a section about EMI, now the picture shown is an earlier version of the one I currently have (which he sent me under warranty), but I decided to double check nonetheless.

The picture shows the earlier model runs a ground cable from the PCB onto the metal casing. Now, Simon claims the new version doesn’t need this since the grounding is done by the design of the encasement and integrated in the PCB (that’s how I understood it, correct me if I’m wrong), in any case, in the latest version he states it’s no longer needed to run a grounding cable.

See the difference here and here

Back when I snapped my original cable in two I remember I installed the new coiled bare wires to DIN and removed the grounding cable because I read somewhere that with shielded cables on your Simucube there’s no need to bother with grounding. Looking back there’s a kind of ahhh moment for me right now because that’s when everything started acting up.

So today after work I decided I might as well try it. Since I still have the original version of the conversion I put the grounding cable back in and reapplied it onto my Simucube.

Besides that I also remembered that because the cable snapped in two I also repositioned it closer to the wheel, which happened to be right underneath the OSW. I also read that running wires close to the OSW might also cause EMI. Therefore I placed it back to it’s original position. Shown here

To make it even more clear this is how it’s setup now and how it originally was. The grounding cable running from the PCB inside the encasement onto the aluminium Fanatec QR. QR with grounding cable attached

So when everything was set and done I obviously got into some racing!

After a good 2,5 hours of racing things look, and I don’t want to get too excited, as if it actually finally did something. I don’t want to fully say it’s solved because I did have two moments where I heard Crewchief’s push to talk activation sound and that button just happens to be bound on the only encased button on the wheel, the red one shown here.

I also had one moment where I thought I had a random upshift but I was also short shifting through a corner so it might’ve been just me accidentally. I’m not 100% sure so I’ll leave this one up for debate.

Other than those two beeps and 50/50 chance of one random upshift however, I didn’t experience any other ghosting, no TC, brake bias, flashing lights, no Crewchief saying he didn’t get that message, the most profound difference were the up and downshifts though. They were far more frequent before which is why I’m even more convinced the outlier was due to my clumsiness rather than EMI.

Ofcourse I’m going to need to do far more extensive testing but right now my feeling is I might need to add some grounding cables to get fully rid of it but at least this made a difference for now.

I hope this post gets read by @phillip.vanrensburg because he knows far more about this subject than I do.

See you soon!

3 Likes

@xuuk3r: Shielding and ground are two different things with USB cables. It MIGHT work, but it also might not.
You need to separate shielding and ground, don’t mix. :wink:

I guess it’s not necessary to provide separate ground to the PCB as the new design eliminated that need.

1 Like

Hi @Joern,

Thanks for the explanation! Like I said in my original post, I know absolutely nothing about electronics.

So do you mean the old version grounds the PCB whereas the new one shields it or did I misunderstand?

If so, do you suggest I need to address earlier parts of the loop? What parts do you think need to be looked at?

Thanks in advance!

Hi @Andreas_Morewood-Myr and @SuperMonaco_GP,

Like I said, I’ve been in touch with Simon back and forth for a while now, I just updated him on what I’ve found and also mentioned you guys are experiencing the same issues. I’ve linked him this post and asked if he could follow up from here. Right now we can’t conclude anything yet but his input can only get us closer to a solution.

1 Like

Allow me to comment a little on the PCB’s and cables.

In the early days of my conversions the Electronics were fitted to a plastic base and often had wires between the pins and plugs. My current kits all use a custom PCB with ground planes on the front and back. They also bolt into the housing and the bolts join the ground of the PCB to the case. That’s why there is no need for an additional ground cable because it would not be doing anything.

The shield / drain wire from the USB cable is basically joined to the ground as well as it is in a normal USB cable. On my kits there is often a spare ground terminal just because I cannot get 5 pin blocks that are any good so I use a 4 pin and 2 pin. The last 3 terminals are all joined and are for grounding.

I have never been able to reproduce any of the issues associated with EMI so it’s really hard to comment specifically.

I have found that Fanatec drivers / software can cause problems and recommend that they are removed if possible from your PC. It is also possible that there is some other software conflict.

To me, if it’s EMI it should be able to be reproduced maybe by moving the USB cable closer to the Motor.

It’s a right mystery.
I sell hundreds of these kits each year and am aware of very few issues (At least with the latest versions)

2 Likes

@xuuk3r: I am also using one of Simon’s conversion kits for attaching a Fanatec BMW GT2 wheel to my Simucube. Worked like that well-known charm at first try.
His kits are not cheap, but worth every penny.

I had to split the cable because I ordered the wrong version without the USB cable, stupid me.
Thus I know the inside of Simon’s cable. It’s flawless, wires of the right colors, proper shielding.
Also the new PCB doesn’t need separate grounding as - as Simon wrote above - the PCB’s direct connection to the housing via screws cares for grounding.
IF there’s a real culprit (shifting issues are often caused by the game itself, a real bad example is Dirt Rally 2.0, and maybe by a slight change of shifting habit due to your I-expect-the-worse-now attitude :wink:), I would look at the part connecting the coiled cable to the rest of your rig.
Possible issues might be caused by:

  • Having the core cables run straight (not twisted) over a longer distance
    This could lead so signal degradation and errors.
  • Gaps in the shielding
    This could open the gates for EMI influence.
  • Overall cable lenght exceeding the limits
    This could cause both of the above issues, also make the cable prone to becoming a kind of antenna for EMI.

That’s what I can think of. I am no USB cable expert, just a guy with a HAM radio licence who forgot more about electronics than he ever learned back in time. :slight_smile:

I would have a closer look at the soldering and shielding/grounding work I did, I don’t expect Simon’s PCB and cable to be the cause of issues.

Hi @simonmaltby,

It was absolutely not my intention to make it sound like the issue is due to your conversion. I’m sorry if it did but it wasn’t where I was getting at.

I’ve had your conversion for over a year without any issues whatsoever so if there was actually a fundamental flaw it would’ve manifested itself way earlier.

You obviously know your stuff and your input likely allows us to exclude a few things. Also, here it’s accessible for everyone who might be dealing with the same issues.

Your suggestion regarding the placement of the USB cable could possibly be spot on. Like I said in my original post, besides trying the original conversion I indeed decided where the DIN connection is held in place on the 8020 frame. It used to be strapped onto one of the frames supporting the OSW’s mount, I might’ve just strapped it to the OSW, that’s how close it was.

Maybe, and this thought just popped into my head, it made it even worse that it was not just the cable but the connection, made out of metal, being so close to the OSW?

I’ve been testing the last three nights now and no issues whatsoever.

I’m going to pop the new conversion back on by the end of the week for confirmation.

I’ll keep you guys posted!

Did not think that at all. I just feel for you when it’s not working.

I just wanted to explain how it all goes together and try to pass on some of the development that’s gone on with the products over the years.

It would certainly be a likely cause if the metal DIN connection was very close to the Motor. Inside the metal would be the least shielded part of the cable and the metal would be a good conductor. I do use the USB cable shield to go to the case of the DIN. This works well on the male but not so well on the panel mount as the material it’s made of wont accept solder.

Simon

Have you properly grounded your racing rig?
Might be easier to follow the guides for ensuring your rig is properly grounded directly to an electricity outlet (not a power strip/extender).
After you know your entire rig is grounded then it might be easier to troubleshoot.