Bumps in Force Feedback


I recently bought a used Simucube 1 with a small Mige and a biss c encoder.
When I start up the Simucube Configuration Tool and Granity, everything seems fine.

Once I load up any Game, the motor gives me very high force feedback every 45° of rotation off center.
These Bumps can also be felt without a sim, if I turn up the Values for Damping, Friction and Inertia in the “Other Filters” Section of the “Filters on IONI drive” Tab in the Simucube Software.
The bumps also get more severe, if i accelarate in game, which leads me to believe that it has to be a software Issue of some kind.

I’m using the newest versions of Granite and Simucube configuration Tool.
I also used the .drc-file provided by the original reseller of the kit, however when used it complained, that the “over voltage fault threshold” was set to low.

Any help is very much apreciated

Probably there is something wrong in the DRC file then, in such way that it doesn’t match the physical configuration with regards to the motor and encoder you have.

Does the wheel rotate at a matching rate compared to real life in the Configuration Tool?


Thanks for the quick reply.

Yes, both in the simucube software and in Granite the rotation gets reported correctly

OK. So did you have to mess around with the wires on the green motor power connector block on the Simucube when you installed the unit?

That might be wrong in the DRC file too. Easiest way to fix would be to toggle the AXI Invert parameter in Granity (if it is now checked, make it unchecked, and vise-versa). Report if this fixed the issue.

No I didn’t touch those. And as far as I can tell, the previous owner didn’t have the same issues as me.

Sadly that didn’t solve the issue.

Hmm, then it is likely a good idea to put the AXI invert how it was.

Can show screenshots of all parameters in Granity? Maybe we can spot something that doesn’t match the Mige motor.

I’ll call this a night and return to this tomorrow.

Sure, here should be all of my Granity settings:
These are the settings provided by the reseller, with the only change from that being the [FOV] being set from 53 to 56





Fault Limits:

Testing (1/2)

Testing (2/2)

Thanks already for the help.

maybe the problem lies with the version of ioni firmware because you have 1.7.21 and it clearly states : * Do not install this in Simucube use case

  • An issue has been noted with this firmware version with Torque mode in Simucube use, when an absolute encoder (such as BiSS-C) is used. We recommend to use 1.7.20 release in Simucube.

try 1.7.20 and see if that helps because i don’t see something wrong in your settings tbh

After installing the older Firmware the issue still persists

The PSU voltage is suspciously high, and that FOV setting leaves the IONI servo drive only one volt or so of headroom to work with to try to dissapate the excess voltage. Is there a reason why the voltage is so high? What kind of PSU is it?

As far as I can tell, the PSU is a NDR-480-48 from Mean Well.
Input is 100-240AC 5.3 A
Output is 48V 10A

There is a voltage adjustment potentiometer on that PSU.I would advice to put the output voltage back to 48.0 V, and after that, the FOV parameter in Granity to 50.0 V.

But that really doesn’t explain why there is a notch at 45 degrees.

However, have you tried to disable the commucation sensor, so that the phase search routine is run on device startup? This would eliminate the change of the encoder having been knocked out of the saved position.

I have set the FOV back to 50 and I have set the voltage potentiometer back down to 48V. It was previously set to a higher value.

I have not tried that.
How do I do this?

Set FCS Commutation Sensor to Off in Granity, save settings, and restart the servo drive.

Okay I did that aswell and the FF is still bumpy :confused:

What I find strange is that the effect gets more pronounced if I increase the ioni filters in SC-Configurator

Yeah, it is as if the current and therefore the magnetic field is not correctly aligned in the motor, causing the notches. More current, more notch-causing magnetic field.

Yes, exactly.
Would this more likely be caused by software or hardware issues?

As we can’t see anything outright wrong in the settings on IONI, my mind would start looking for wiring faults, especially with regards to motor phase wires. If some of the phase wires do not carry current enough to the motor, it would cause the notches.

If that is not the cause, then maybe the IONI is broken (some type of mosfet failure?) but it is very unlikely, we have maybe seen one in Simucube use case over these 6+ years.

Simucube fault would be unlikely, as the Simucube in this case is just a board that carries the current from IONI to the connector for the motor.

So afaik the wiring in the cable from the Simucube board to the motor might be the issue.

The markings on the pcb do not align with the markings on the cable/sc-connector.
The Current pins on the board are currently connected with these pins on the connector:


How should the wires be connected, or could this somehow be the correct way to connect them?

I’m not sure what you mean, but here is the wiring:


Motor phase 4 is for stepper motors, so you would use U V W (empty) GND
and the e-stop in the last pins.