Brand new Simucube issue - DFU mode won't work

Hey guys,

Got a brand new Simucube and Ioni Pro HC I’m trying to set up, however I’m having an issue connecting to it through Windows.

I’m getting an error straight off the bat with my Simucube when trying to flash firmware for the first time (in Windows). Dfuse Demo installed (tried 3.0.5, and 3.0.6).

The error is as follows (when connecting via X3):
USB device not recognised
The last USB device you connected to this computer malfunctioned

I’ve tried multiple USB cables, uninstalling the driver, reinstalling. I’ve tried multiple versions of Dfuse, no good. I cannot get the Simucube to go into DFU mode no matter what I do.

The LEDs that flash are:
3 Short 1 Long

I’ve tried multiple power supplies (both 24v and 48v)
I’ve tried the other Simucube board in DFU mode, and it works.
I’ve tried another PC with the Simucube board, it doesn’t work on the other PC.

Any other suggestions on what I can do? I think I’ve got a DOA board.
This is my second Simucube based setup, so I have been through the process of building and setting up before.

I’ve raised a Ticket, however haven’t heard back just yet.


Did you check in cevice manager under usb-
Stm32 bootloader?

Of course. It was listed as an unknown device and you could not force any drivers on it.

It turned out to be a DOA Simucube board. Ordered another one and it worked first go, so I’ll be returning the DOA part for a refund.


mine was listed as stm32 bootloader forced stm32 dfu loader and worked fine

Different problems, mine would not go into DFU mode at all. It was a faulty unit.