AsRock USB problem with my osw wheel [SOLVED]


I’ve recently received my osw bundle from Tomo and have encountered unusual problem. I’ve been frustrated whole weekend with it. In short the wheel disconnects when i try to drive in assetto corsa and starts turning to one direction. It happens in Online race instantly, in race with AI instantly also, but in hotlaps it is pretty random. I might drive hotlaps for few hours and if I try to enter an online race or race with AI it might crash after few laps but mostly it crashes instantly. In this case i have to exit Assetto corsa game and reboot the simucube with the on-off switch. Sometimes it freezes my PC also, so I have to restart.

I have tried everything - connecting grounding wire case->motor; PC case->motor; metal rig->motor; house grounding->motor and countless more variants.

I figured that if the cables of data and power radiate electromagnetic field and interfere with each other, so i separated them and wrapped them around my metal rig - it helped for a few hours of hotlaping but not for much else.

Let me get to the point. Tomo has advised me to use USB Hub or PCI Express USB board since my USB ports might be a little ‘sensitive’. I brought my laptop and connected simucube to it. The wheel works fine in any mode.
Then i brought my PC to a friend (LAR555) and tested it on his simucube set, the problem appeared on his rig either!

We tried connecting through USB hub, but the connection problem came up (as if connected through usb 3, unlimited beeping in windows as if new device was just connected)

I cannot test it with PCI express USB board since my motherboard is mini-ITX and it has no PCI express slot.

I also tried changing up some settings in BIOS regarding the USB slots but it did not help.

In granity it says fault code 481001.
Same goes for iRacing.
P.S. The only USB 2.0 ports on my motherboard are some ‘fancy’ “FATAL1TY MOUSE PORTS”
P.S.S. also my PC does not start while the motor is powered on.


AsRock Fatal1ty X370 Gaming-ITX/ac
Ryzen 1600
16gb ram
ASUS GeForce 1080ti

EDIT: Also my device manager keeps refreshing after the simucube crash (link)

Which firmware version are you running? If you have 0.9.8, you can try to downgrade to 0.9.7.

I used the 9.8. Just tried 9.7 and it is the same regarding my problem.

Did you actually flash 0.9.7 too?

Button ‘start everything from scratch’ does not seem to work in my case. If i press it nothing happens and the settings i applied earlier stay

edit: also simucube is not shown in my devices.

have you installed the game again?
( I had the same issue in the newest rFactor and the problem was not the OSW but a controller ini file value wrong)
I mean your friend has the same problem on your computer
maybe it is the game configuration file and not the OSW

Yes, I have. As I said the same problem persists in iRacing.

I have seen this before on some Asrock and Asus boards, it is the USB chipset mucking you around.

Is there any onboard USB 2 headers (native) on that motherboard, then you can run a USB2 to the rear of your PC via one of those USB2 adapters…

I am willing to bet this is your issue with those USB 3 ports at the back.

I have an older Asus X79 WS board here that have a few USB 3 ports connected to a specific controller that exhibits the same behaviour…

Edit: I had a look at your motherboard manual, try those 2 USB 2 ports above the PS2 connectors on the back - there also should be one USB2 header on the board, you can use a rear USB2 I/O connector to see if it improves.

Otherwise, if not, you’re up for a new system, I am afraid.


1 Like

I have an AsROCK z270 board with no issues… I run the SimuCUBE off of the internal USB2 Header… I am not sure about compatibility of the USB3.0 Ports… The Fatal1ty Mouse port is actually just a normal USB port with polling rate control (I personally don’t use it) so as Beano mentioned you can probably just use those two ports without issue.

You can also sort the devices in Windows Device Manager by “devices by connection” by using the View menu. You can then verify, that a given device (like SimuCUBE) is connected to a Intel supplied USB Hub. Screenshot below, however I do not have SimuCUBE turned on and I’m writing this through a Remote Desktop connection.

1 Like

Hello, everyone, thank you for your time while trying to resolve my problem.

Beano, I have connected usb 2.0 port to internal usb2.0 header. Yet the problem stays.

I figured i can disconnect my motherboard usb 3.0 connectors via BIOS, but it was no help either.
I think my problem could be solved with BIOS configuration, since i played a bit with it and Assetto Corsa began crashing also while simuCUBE was disconnecting.
Also there is many configurations in my BIOS regarding USB ports which i do not particularly understand. I will upload some pictures of it so maybe anyone is better at it than I am.


As regarding Mika’s reply, I’ve made a screenshot of my Device Manager.



So now when the wheel disconnects during the game, beeping sound starts as if new device was connected.

This happened after i connected card reader with USB 2.0 to my internal USB 2.0 connection. It does not matter where the simuCUBE is connected - card reader or motherboard usb 2.0, either do the same beeping sound.

This happens also if i power on the simuCUBE and relocate it to another USB. It does not connect automatically and starts glitching the beeping sound. It comes alive if only when I plug the usb first and then power-on the simuCUBE.

I’ve been having weird USB issues with my ASRock Z370 Extreme4 system as well. Except in my case, it’s my USB headset that drops out instead of my wheel, leaving me with no sound in-game.

I’ve tried many things to no avail. I even went so far as to RMA my motherboard, but it continues to be a problem, even with the new replacement motherboard. Wish I had a solution for you, but I haven’t found one yet.

Today I ordered a PCI-E USB 3.0 adapter in hopes that it will finally solve my USB dropout issues.

I hope your PCI-E helps you.

I did some testing of my own. So it does not even need to use the wheel to disconnect. As soon as i launch video benchmark in Assetto corsa it disconnects. No matter the settings high/low.

Afterwards i did some GPU and CPU stressing with Furmark and Prime95, but the weel does not disconnect. It only disconnects as soon as i launch iRacing or Assetto corsa race/benchmark.

Any ideas?

Ok, so I investigated some more and figured out that my motherboard treats its usb 2.0 ports as usb 3.0 ports. Technically they are USB 2.0 ports but ‘treated’ differently. Maybe anyone has a solution for this nonsence?

This is the first report of funny things going on with the AMD chipset. You didn’t answer whether you tried to flash 0.9.7 or not, it is done by manually running the Firmware Update wizard from the 0.9.8 up to the point of it saying “Found SimuCUBE in firmware update mode”, and then using 0.9.7 to continue.

So i downgraded to 0.9.7 and it seems to work! I’ve driven couple laps in iRacing. But the best part is that if i un-plug simuCUBE from usb and plug it back - it recognizes the simuCUBE without restarting it! Will test more tomorrow and leave the feedback here. Thank you.


So my setup works fine, the downgrade to 0.9.7 works. Thanks to everyone who tried to solve my problem, especially Mika.

Have a nice day, see you on the track!

I will have to find another solution to the “SimuCUBE stops responding after reboot” issue. The fix that was in 0.9.8 doesn’t seem to work, although it seemed to be very good in pre-beta testing.