Ascher not detected anymore

hello, i have not raced in a few months but when i started it up my wheel is no longer begin detected.
battery is fine wheel is on.

power cycled everything multiple times, updated to 2022-2 but its just not showing up in the software


Holding both shifter paddles for some Seconds doesnt work?

Is the Ascher not detected or is the wireless wheel receiver module not detected? We are getting a fix out for the latter this weekend.

Any other testers for the firmware?

holding the paddles does nothing. (just flashes green for a few seconds)

i am getting a different battery tomorrow just to be sure.

im not sure how to check the difference between ascher not being detected or the wireless receiver not being detected , how can i tell?

Any other testers for the firmware?

Hi Mika. Yes, still needing a proper fix here to work with Ascher wireless as well.

oh it says the receiver is not detected. reading is hard :smiley:

My Ascher wireless wheel stopped connecting for me a couple of weeks ago. I changed the battery for a new fresh one, and works perfectly again, no issues.

Happened to me too on 2022.2. My Ascher F28SC wasn’t detected. Once I downgraded to 2021.12, it worked just fine.


I’ve updated today from version 2022.2 to version 2022.7 and my Ascher F28SC does not show up in the wireless dialog any longer. It flashes green, but it does not show up. I’ve tried downgrading to 2022.5, then 2022.2, then 2019.9, then 2019.12 but all of them exhibit the same behaviour.
I’ve removed the battery from the wheel and tested it’s voltage and it outputs 3.58V, so I’m assuming it’s almost full (the battery says 3.6V in the package)

I’ve tried hitting the clear list and restart scan, but the wheel never shows up in the list. I don’t have the message saying wireless adapter not found.

Anybody has any other ideas?

Contact our support for some troubleshooting steps.

Thanks Mika.

I will do that tomorrow, if the problem persists. I’ve taken the wheel to my brother’s simucube and it exhibits the same behaviour. I think this might just be the wheel’s battery, so I’ll buy a battery tomorrow first!

edit: it was the battery. just for clarification on what I was seeing for others encoutering for this information, the wheel was blinking green, but it wouldn’t connect. I guess it was just boot looping. nevertheless, replacing the battery made it work

Sounds like you have isolated the issue to the wheel.