Ascher F28-SC V2 Disconnecting

Hi team

Recently got my hands on a Simucube 2 Pro and been loving it. I have been having an issue where my F28-SC V2 rim will randomly disconnect then reconnect, sometimes it may do this 3-4 times at once. Has anyone else experienced this or potentially have a fix?


Did you get a brand new R2 version pro with the little antenna on the back?

I keep my antenna angled a bit so it hangs over the side, almost as if it was peering around the back of the simucube to get line of sight to the front.

I’ve read posts of people having issues that were solved by updating the truedrive software and firmware, are you on the latest version?

Lastly, I’ve heard of people with intermittent button presses not getting picked up and they said they solved that issue with a new battery in the Ascher F28.
Since the batteries are pretty cheap, I would start with that.
(If you’re in the US, it looks like amazon has them in 4 packs for $10)
(Battery type is ER 14250 for the F28V2) )

Yes I have the R2 version, I did try the positioning of the antenna but that didn’t seem to help much. I’m running the current 2021.8 software and it hasn’t seemed to have been an issue since upgrading to that (fingers crossed)

Joe, I think that’s more than a coincidence - I’ve read of others who’ve solved the same issue with a firmware update.

Do you happen to remember what firmware you had prior?

I’ve only ever used 2021.7 and now 2021.8 and both worked fine with my F28.

It is very unlikely but still possible, that some random disconnects were an issue in all 2021.x firmwares until the 2021.8 release.

1 Like