Argon/MiGe setup, wheel won't phase

MiGe 10nm
I/O 2100

Hello everyone,
I’ve had my DD wheel sitting in the garage for 3-4 years and set it up again yesterday, but I can’t get it to work. I had the same old granity software and mmo’s on an external drive, and if I remember corrrectly, last time I set it up I only had to run mmo’s and I was good to go.

Now when I power it up the blue light on the disco blinks, but the wheel won’t start phasing. If I turn it slightly the light turns off. I loaded up iracing and it registers the wheel inputs, but obviously no ffb.

At a loss of solutions I tried updating the firmware last night, but I ran into a problem when I had to adjust the settings in granity as I don’t have a motorsettings file. I found a couple online, but I have no idea if they are correct.

Mmo’s has displayed the green icon all along, so I haven’t touched the Mmo’s firmware yet. (I also don’t have the hex file)

Granity has a red exclamation mark on Initialized, Enabled and Phys enable.

Hope someone is able to help

Screenshots below

if Granity has red exclamation mark at Phys Enable, then physical enable signal is not on, and the phasing is not being done. Check the wiring to the IONICUBE.

A wire was indeed loose, thank you!

Phasing now works, but forces feel strange. When I turn approximately 20 degrees to either side, the motor forces the wheel to 90 degrees. Also, with emergency stop active, there seems to be a constant force/drag on the wheel, while last time I used it I think I remember it having nothing.

I suspect my granity settings are wrong, if someone could have a look at those I would really appreciate it. And I’m using the Argon if that makes a difference.

I guess encoder settings are wrong. Do you know what type of encoder you should have?

The info you need is in the document at this link.

PPR was too high among a few other settings.
Problem solved, thank you all so much!

1 Like

Glad you got it sorted out!