Argon Enable in signal


#1

Hi,

We have two brand new Argon drives in our Linuxcnc machine.
Step and dir signals of J5 are used for motions.
STO1 and STO2 signals of J2 port on first drive are connected to the emergency circuit of the machine.
Enable input signal on first drive is connected to the safety door to prevent motions while the door is open.
Drives are connected together with RJ45- cable.
Problem is that randomly either drive does not go to enable-state even when Enable input signal is present.

Any Ideas?


#2

Hi!

Can you connect to drive with Granity and see what status & fault bits there are active when this occurs? If you can post copy & paste or screenshots where, it will speed up the solution.

BR Tero


#3

Hi Tero,

In this situation both STO and Enable in signals are connected.
I cannot clear faults by Granity software.
But if I disconnect 24V of J3 for couple of seconds, then errors dissapears.
Same thing when powering up the argon, if 24V is connected before Enable in, sometimes Enable- state is not activated. If 24V of J3 is the last signal connected, drives always goes Enable- state.

-Petri


#4

Hmm, it’s likely a firmware bug. I’ll put it on my backlog to fix it. However I’m busy next 2-3 weeks at least so until then can you use some workaround?


#5

We have changed safety door functions from Argon through Mesa to Linuxcnc.
Now it works fine and I think we will keep it in that way.


#6

Good hear that! We’ll take a look on this in firmware level regardless to iron out the issue.