Argon 400 pulse tracking error with Yaskawa 1.8Kw USAFED servo motor


#1

My hardware configuration:
-(drive type) Argon
-(motor type/model) AC servo 8P, YASKAWA USAFED 20FB2T, 1.8KW, 15A, 1500RPM,11.7Nm , 8 counted poles
-(drive firmware version) Latest
-(other details)

Problems arise when:
-(describe how/where it happens)

Tracking error above 150 raw pulses at 100mm/s2 with max 5A current .
At 500-750mm/s2 tracking reaches 400 raw pulses (5000PPR/encoder)

How it behaves:
-(describe system behavior)

On the table position error is big regardless P I settings
Increasing P above 4000 will produce oscillations.

How I would expect it to behave:
-(describe)
Have better position tracking as it has enough current reserves .
At 100mm/sec2 is using only 5A with 150 pulses error in position tuning with Granity .

I have attached following files:
-(consider adding saved Granity configuration file .drc)
-(screenshots)

I also would like to share that (additional info).

Note: you can tag the best answer as solution. This helps others to find the solution to the same question.


#2

Hi Rirazvan

Have you checked these instructions?
https://granitedevices.com/wiki/Tuning_position_controller

Kind regards,
Esa


#3

Hello
We did follow the instructions to tune it.settings24.10.drc (7.4 KB)

We measured both coils resistance and inductance with precision devices. what we did wrong? Motor has max 2500RPM.


#4

Hi Rirazvan

Even you measured the motor resistance and inductance with quality instruments, you might still want to fine tune them in the settings to get the best result.

In position and velocity mode you also seem to get close to good results, and you only need to adjust the tuning parameters to get wanted results.

You have position feedforward gain (PFF) 110, and this can lead to overshooting. Try to lower that to 100. Also, you have KPP quite much lower than KVP and you could try to increase that.

Kind regards,
Esa