Analog joystick (Hat Switch) not working on Simucube inputs

Just stumbled on this forum while trying to find a solution on the iracing forums! I am trying to wire a Alps 4 way joystick/hat switch to the Simucube. I was trying to use Lower 11 but I am not getting any input from the 2 axis. The push to click button is registering fine. I have tried all 4 options under Analogue inputs in MMOS. Output voltage looks correct using a meter on the outputs. Are the Analogue inputs functional on the Simucube at this time? Should I be using a different input? Thanks for assistance you can provide!

We don’t offer support for using and configuring the 3rd party MMOS firmware. However, I do know that it is possible to use, for example, Logitech G25/G27 pedal sets with them, if wired correctly and analog axises enabled in MMOS settings.

We are in progress of creating a new open-source firmware, and one of the first things I implemented on it, was working analog inputs. In the firmware, they are now very intuitive to set up, calibrate and use.

I can’t promise you a release date for the start of the open beta test period, though.

1 Like

Taking another look at this.

The wiki page shows the default analog inputs for gas/clutch/brake, and it is wired on X11 upper connector. I suspect it is not possible to use any other connectors than X11 Upper for analog inputs with MMOS.

Thank you for the responses! I tried X11 lower because they appear to be Analog also and fit my needs with the buttons but I guess not. I will try X11 upper tonight. I can’t wait for the updated firmware! Thanks again for all your work on this!

1 Like