AMS 2 loss of steering and FFB

Hey guys, you are my last hope. This might not even be a Simucube issues but I struggle for a full week, googled for 10+ hours and also reinstalled windows about 3 times with out any luck.

When playing AMS2 (it happens in AMS2 only) and changing focus to another app (alt+tab) my SC2 Pro loses all steering and ffb ingame. In Truedrive and Windows everything is still working fine though. So this might not be a SC2 issue.

If I restart AMS2 it works again until it loses focus again.

I tried 100% clean install of Win10 and Win11 and installed AMS2 fresh from Steam (no backup from external drive), tried it with and without Simhub but nothing makes a difference.

Did anybody ever had the same issue?
Thank you in advance

Game enters Pause mode/no ffb when screen focus is lost, but ffb comes again as soon as I enter to track

It’s not coming back. Steering is dead (no turning possible), no ffb and I can’t calibrate wheel in game. It’s completely gone until I restart the game.

It’s getting weirder. This morning I hooked up my other USB wheel, and everything works… wth?
I plugged in the other USB wheel again, and it starts acting weird acting.

How can a usb wheel intefer with the SC2?
Shouldn’t it be completly seperated?

Did you try a different USB Port, some boards are using internal USB hubs for some ports, but I know it is hard to figure out which are controlled by the chipset directly. Esp. many new low/mid end boards/chipsets (e.g. =already high price AM5 boards have only 4-5 of the ports w/o hub).

Also USB sleep mode could be a possible issue - search for ‚usb sleep energy setting‘ to see how to turn itoff.

Thanks for your input. I tested all ports, replaced all usb cables, from all devices but the problem still exist.

I also disabled selected energy saving on usb ports but it didn’t make a difference (I don’t think it’s an energy problem since no device is really disconnecting, it still works fine in true drive)

This morning it worked for a an hour, but when i switch the wheel the problem is back.

In this moment I’m installing joy2key to assign each usb device to it’s own joystick number. Maybe it’s beacuse Windows is changing ports…

It’s a long reach but I don’t know what else to do…

Are you using SimHub Control Mapper? Disable if you do, there were bunch of reports recently on issues with that one.

No, I also tested the system after a clean install of the os without simhub and any other mapping tools installed and it behaved the same.

Are you using a custom FFB file? If yes try with the default or the opposite and see if this continues. I remember a couple of years back i had some similar issues with some custom files. Not saying that this is the problem in your case but since you have done everything else, it is worth giving this a shot.

Thank you, I never thought of the custom ffb. I use Daniel Kart‘s file. I will give it a shot when I‘m back home.

I finally figured it out and maybe someone can reproduce it.

The problem is mapping of “extra brake” in AMS 2. As soon as I map an Input (no matter if it’s a controller or just a keyboard input) the wheelbase lose all function on alt+tab (or when AMS2 loses focus).

If I remove the mapping and tabbing out and back into the game SC2 is fully functional again. I don’t even have to restart the game.

I don’t know how this is related to each other but I can reproduce it 20 times in a row.
So I’m pretty sure it’s the cause…

I tried AMS2 yesterday to try the RX cars and had no issues with extra brake bound to my handbrake

Not sure if this will make a difference but I am running my game in windowed borderless and alt tabbing or open Chrome for example doesn’t cause me to lose FFB

Thank you, but it happens independend from the window mode.

I talked to two other Simucube drivers and they dont have the issue either.
Seems only to affect my system.

:checkered_flag: After 1 year I finally figured out whats happening. At least it’s working for now. I believe AMS2 has a device limit. If you use too many devices one gets kicked during the game. Since I combined my 2 buttonboxes with the Simhub Control Mapper to a single device I can map the handbrake again without losing FFB.

1 Like